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Chapter 1

Getting started

This chapter helps you install and run MuseScore for the first time. The
chapter will also show you how to create a new score.

Installation
MuseScore works on many different computer systems including, Windows,
Mac OS, and Linux.

Windows
You can get the Windows installer from the Download page of the MuseScore
website. Click on the link to start the download. Your Internet browser will
confirm that you want to download this file. Click "Save File".

When the download finishes double click on the file to start the installation.
Windows may open a security window and ask you to confirm before running
the software. Click "Run" to continue.

http://musescore.org/en/download
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The installer recommends that you close all other applications before
continuing. After you close the other applications click "Next" to continue.

The setup wizard displays the terms of the free software license which you
may review. Click "I Agree" to continue.

Next it confirms the location for installing MuseScore. If you are installing a
newer version of MuseScore but still want to keep the old version on your
computer then you should change the folder. Otherwise click "Next" to
continue.

Next it confirms the name for the MuseScore folder that appears in the
Windows Start menu list of programs. Click "Install" to continue.

Give the setup wizard a few minutes to install the necessary files and
configurations. When it is done click "Finish" to exit the installer. If you wish,
you may now delete the installer file you downloaded.

Start MuseScore
To start MuseScore choose Start → All Programs → MuseScore → MuseScore.

After several seconds MuseScore will open up to the demo score. Feel free to
experiment with the demo score and get the feel of the program. Next you
may want to create your own score.
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Advanced users: Silent or unattended install
You can install MuseScore silently with the following command
MuseScore-1.0.exe /S /D=C:\Program Files\MuseScore

You can uninstall with
cd C:\Program Files\MuseScore

Uninstall.exe /S

Mac OS X

Install
You will find the Mac dmg file on the Download page of the MuseScore
website. Click on the link to start the download. When download is finished,
the dmg file is automatically mounted on your desktop as "MuseScore-0.9.6"
and the installer appears.

http://musescore.org/en/download
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Drag the MuseScore icon and drop it to the Applications folder icon. If you
are not logged in as an administrator, Mac OS X will ask for a password:
click "Authenticate" and enter your password to let Mac OS X copy
MuseScore into your Application folder.
You can now launch MuseScore from Applications or SpotLight.

Uninstall
Just delete MuseScore from Applications folder.

Linux
Please see the Download page for instructions pertaining to MuseScore on
Linux. Packages are provided for Debian, Ubuntu, Fedora and PCLinuxOS.
Other distributions will require you to build the application from source. For
instructions specific to Fedora see below.

Fedora
Import the GPG key:

su

rpm --import http://prereleases.musescore.org/linux/Fedora/RPM-GPG-KEY-Seve

http://musescore.org/en/download
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2. Go to the download page of the MuseScore website. Click on the link for
the stable Fedora download and choose the correct rpm package for your
architecture

3. Depending on your architecture, use one of the two sets of commands
to install MuseScore

if for arch i386

su

yum localinstall musescore-0.9.4-1.fc10.i386.rpm

or if for arch x86_64

su

yum localinstall musescore-0.9.4-1.fc10.x86_64.rpm

If you have difficulty with sound, see Fedora 11 and sound.

Attachment Size
install_mac.png 62.18 KB

http://musescore.org/en/download
http://www.musescore.org/en/node/3848#comment-9634
http://musescore.org/sites/musescore.org/files/install_mac_0963.png
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Chapter 2

Basics

The "Getting started" chapter above guides you through the Installation and
process for creating a new score. The "Basics" chapter gives an overview of
MuseScore and describes the general methods for interacting with the score.

Note entry
Adding notes and rests to a staff requires four basic steps:

1. Select your starting position for note entry

2. Select Note entry mode IMPORTANT! (This is where most mistakes
occur)

3. Select the duration of the note (or rest) you want to enter

4. Enter the pitch (or rest) using keyboard shortcut, mouse or a MIDI
keyboard

To add notes of different durations that play at the same time, see Voices.

Step 1: Starting position
First select a note or rest on the score as your starting position for note
entry. Note entry in MuseScore replaces the existing notes or rests in a
measure with your new notes (i.e. overwrites rather than inserts). However
you can insert new measures at any point (see measure operations, "Insert")
or use copy and paste to move a passage of notes.

Step 2: Note entry mode
The "N" button on the Note Entry toolbar indicates whether you are in note
entry mode or not. Besides clicking the button you can using the following
keyboard shortcuts.

• N: Enter Note entry mode
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• N or Escape: Leave Note entry mode

Step 3: Duration of the note
After entering Note entry mode select the duration of the note you need from
the Note Entry toolbar or use the corresponding keyboard shortcut.

The keyboard shortcuts for selecting the note duration are:

• 1: 64th note (hemidemisemiquaver)

• 2: 32nd note (demisemiquaver)

• 3: 16th note (semiquaver)

• 4: Eighth note (quaver)

• 5: Quarter note (crotchet)

• 6: Half note (minim)

• 7: Whole note (semibreve)

• 8: Double whole note (breve)

• 9: Longa

• .: A period (dot) changes the selected duration into a dotted note

Step 4: Enter pitch
For all instruments (except unpitched percussion) you can add note pitches
using the mouse by clicking directly on the staff. (For instructions specific to
percussion see Drum notation). However you may find it quicker to use a
MIDI keyboard (see below) or your alphabetical keyboard. The following
examples use a standard computer keyboard.

Enter pitches by typing the corresponding letter on your keyboard:
C D E F G A B C

0 (Zero) creates a rest: for example C D 0 E. Notice that the duration you
select for the notes (quarter/crotchet notes in this example) also determines
the duration of the rest (quarter/crotchet rest)

Please note that in versions 0.9.6 and earlier, Space creates a rest. In the
latest versions of MuseScore Space starts playback.

During note entry MuseScore automatically advances in the score. If you 
want to add a chord note to your previous entry, hold Shift and enter a note 
name: C D Shift+F Shift+A E F
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To create chords with notes of different durations see voices.

If you want to create a dotted note, press .. For example 5 . C 4 D E F G A

When you type a note on the keyboard MuseScore chooses the octave closest
to the previous note to entered. To shift your note up or down by an octave
use the following keyboard shortcuts:

• Ctrl+↑ (Mac: ⌘+↑): Increase the pitch of a note by one octave.

• Ctrl+↓ (Mac: ⌘+↓): Decrease the pitch of a note by one octave.

Other useful editing keyboard shortcuts available in Note Entry Mode:

• ↑ (Up): Increase the pitch of a note by a semitone (uses sharps).

• ↓ (Down): Decrease the pitch of a note by a semitone (uses flats).

• R: Duplicate the last entered note

• Q: Halve the duration of the last entered note

• W: Double the duration of the last entered note

• Backspace: Undo last entered note

• X: Flip direction of note stem

• Shift+X: Move note head to opposite side of stem

MIDI keyboard
You can also insert pitches using a MIDI keyboard in MuseScore version
0.9.6 or later.

1. Connect your MIDI keyboard to the computer and switch your keyboard
on

2. Start MuseScore

3. Create a new score

4. Click to select the rest in measure 1 to indicate where you want note
entry to begin

5. Press N to begin note entry mode

6. Select a note duration such as 5 for quarter notes (crotchets), as
described above

7. Press a note on your MIDI keyboard, and notice that the pitch is added
to your score
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Note: the MIDI keyboard enters one note or chord at a time. This mode of
note entry (often called "step-time entry") is fast and reliable. Some notation
software tries to interpret "real-time entry" where the musician plays a
passage and the software tries to create the notation. However the results
are frequently unreliable even when played by a skilled musician using
expensive software. MuseScore's focus is on more reliable forms of note
entry.

If you have multiple MIDI devices connected to your computer you may need
to tell MuseScore which one is the MIDI keyboard. Using version 0.9.6 or
later go to Edit → Preferences... (Mac: MuseScore → Preferences...). In the
preferences dialog click on the I/O tab and select your device under the
section labeled "Choose PortMidi input device".

Coloring of notes out of playable range
MuseScore colors out-of-range notes as yellow or red in versions 0.9.5 or
later. Notes above or below the comfortable range of an amateur appear
yellow, note beyond the comfortable range of a professional appear red. The
colors are informational and appear on the computer screen but do not
appear on printed copies of your scores. To disable note colors in versions
0.9.6 or later choose Edit → Preferences... (Mac: MuseScore → Preferences...), click
on the Note Entry tab, and unmark "Color notes outside of usable pitch
range".

See also
• Drum notation

External links
• Video tutorial: Note entry basics

Attachment Size
noteentry1.png 4.36 KB
noteentry2.png 2.54 KB
noteentry3.png 2.57 KB
noteentry4.png 2.94 KB
note-entry-4.png 4.09 KB

Copy and paste
Copy and paste is useful tool for repetitious music or for shifting a section of
music by a beat or two.

Copy
1. Click on the first note of your selection

http://www.youtube.com/watch?v=ugzgezapbge
http://musescore.org/sites/musescore.org/files/noteentry1_0.png
http://musescore.org/sites/musescore.org/files/noteentry2_0.png
http://musescore.org/sites/musescore.org/files/noteentry3_0.png
http://musescore.org/sites/musescore.org/files/noteentry4_0.png
http://musescore.org/sites/musescore.org/files/note-entry-4.png


11

2. Shift+click on the last note of your selection. A blue rectangle should
highlight the region you selected.

3. From the menu choose Edit → Copy

Paste
1. Click on the note or measure that you want your pasted selection to

begin

2. From the menu choose Edit → Paste

Edit mode
Many elements in the score can be edited in Edit Mode :

• Double Click: Starts Edit Mode

• Escape: Ends Edit Mode

Some elements show handles in edit mode which can be moved by mouse
dragging or keyboard commands.

Slur in Edit Mode:

Available keyboard commands:

• ←: Moves handle left one Space

• →: Moves handle right one Space

• ↑: Moves handle up one Space

• ↓: Moves handle down one Space

• Ctrl+← (Mac: ⌘+←): Moves handle left 0.1 Space

• Ctrl+→ (Mac: ⌘+→): Moves handle right 0.1 Space

• Ctrl+↑ (Mac: ⌘+↑): Moves handle up 0.1 Space

• Ctrl+↓ (Mac: ⌘+↓): Moves handle down 0.1 Space

• Shift+←: Moves handle's tick anchor left

• Shift+→: Moves handle's tick anchor right

• Tab: Goes to next handle

Sometimes you may manually need to move horizontally a note or even a 
sharp/flat . If that is the case, just double-click it and then use the arrow keys
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left/right.

See also: Text editing, Slur, Bracket, Line

Measure operations

Append
To add a measure to the end of the piece press Ctrl+B (Mac: ⌘+B), or from the
menu choose Create → Measures → Append Measure. To add multiple measures
press Ctrl+Shift+B (Mac: ⌘+Shift+B) or use the menu Create → Measures → Append
Measures....

Insert
First select a measure then press Ins or use the menu Create → Measures →
Insert Measure to insert a new empty measure before the selected one. To
insert multiple measures press Ctrl+Ins (Mac: ⌘+Ins) or use the menu Create →
Measures → Insert Measures....

Delete
First select the measure then press Ctrl+Del (Mac: ⌘+Fn+Backspace).
For 0.9.5 and earlier, it's different. Press Ctrl (Mac: ⌘) on the keyboard as you
click on an empty part of the measure with the mouse. The measure is
marked with a dotted line indicating that you selected a "piece of time".
Press Ctrl+Click (Mac: ⌘+Click) to extend the selection. Pressing Del (Mac:
Fn+Backspace) removes the selected measures.

Properties
To edit the properties of a measure right click on an empty part of the
measure and select Measure Properties....

Staves
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The Visible property allows you to show or hide the notes and staff lines for
the current measure. The Stemless property allows you to show or hide all
note stems for the current measure. Notes that normally have a stem such as
half notes (minums) and quarter notes (crotchets) only show the note head
when marked as stemless.

Duration
The Nominal duration is the time signature that is displayed on the score.
You can change the Actual duration of a measure to anything regardless of
the time signature displayed on the score. Normally the nominal and actual
duration of a measure is identical. However a pickup (upbeat) measure for
example can have a shorter actual duration.

In the figure below the quarter note (crotchet) pickup has a nominal measure
duration of 4/4 but an actual duration of 1/4. The measures in the middle
have both nominal and actual durations of 4/4. The complimentary measure
with only a dotted half note (dotted minim) at the end has an actual duration
of 3/4.

Irregular
An "irregular" measure is not counted in the measure numbering. Normally a
pickup measure is marked as "irregular". If you are using version 0.9.4 or
earlier and mark a measure as irregular then you may need to save and
reload the score before the measure numbers show the change.

Add to measure number
You can also use the "add to measure no." option to influence the measure
numbering. You can enter positive or negative numbers here. Please note
that this affects subsequent measures. A value of "-1" has the same effect as
marking a measure irregular.

Layout stretch
You can increase or decrease horrizontal space between notes with this
option.

Repeat count
If the measure is the end of a repeat you can define how often the repeat
should be played.

Break multi-measure rests
This property separates a multi-measure rest at the current measure. This
option should be checked before you turn on the "Create multi-measure
rests" option in Style → Edit General Style.

Versions 0.9.6 and later automatically break multi-measures at important
breaks such as rehearsal marks, time changes, double bar lines, etc.
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Numbering
MuseScore automatically numbers the first measure of each system but
more numbering options are possible. From the main menu choose Style →
Edit Style. In the left pane choose "Numbers". In the bottom half of the right
pane is the "Measure Numbers" ("Bar Numbers") section.

Mark the checkbox next to the "Measure Numbers" ("Bar Numbers") to turn
on automatic measure numbers.
Mark "show first" if you want the first measure numbered.
Mark "all staffs" if you want numbers on all staffs, otherwise only the top
staff of each system shows measure numbers.
Choose to show numbers on "every system" which numbers the first measure
of each line, or show numbers by "interval" and specify the size of the
interval. For example, an interval of 1 numbers every measure; an interval of
5 numbers every fifth measure.

Palette
You can show or hide the palette using the menu Display → Palette.

You can drag-and-drop palette symbols onto score elements.

Double clicking a palette symbol is equivalent to drag-and-dropping this
symbol to each of the selected elements on the score.

For example you can quickly add tenuto marks to a group of notes:

1. Select notes

2. In the Articulations/Ornaments palette, double click on the tenuto
symbol

Undo and redo
MuseScore has unlimited undo/redo functions.

The standard shortcuts are:

• Undo Ctrl+Z (Mac: ⌘+Z)

• Redo Ctrl+Shift+Z or Ctrl+Y (Mac: ⌘+Shift+Z)

Or use the toolbar buttons:
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File format
MuseScore supports a wide variety of file formats, which allows you to share
and publish scores in the format that best meets your needs. You can import
files via File → Open... and export via File → Save As.... In addition to the formats
detailed below, you can save and share your scores on the web at
MuseScore.com File → Save Online....

MuseScore native format

Compressed MuseScore format (*.mscz)

MSCZ is the standard MuseScore file format and recommended for most
uses. A score saved in this format takes up very little disk space but
preserves all the necessary information. The format is a ZIP-compressed
version of .mscx files and includes images.

MuseScore format (*.mscx)

MSCX is the uncompressed version of the MuseScore file format used in
version 0.9.5 or later. A score saved in this format will not lose any
information except images and is recommended if you need to manually
edit the file format using a text editor. Previous versions of MuseScore
used the MSC file extension. However MSC conflicts with a file extension
used by Microsoft Windows and is blocked by some email providers. The
new MSCX file extension supersedes the old MSC file extension due to
the problems outlined above.

Note about fonts: MuseScore does not embed fonts in the file. If you want
to share a MuseScore file with other parties choose a font for your text that
the other parties have installed. When a computer does not have the fonts
specified in the file, MuseScore uses a fallback font instead. Of course the
fallback font will look different.

MuseScore backup files

MuseScore Backup File (.*.mscz, or .*.mscx,)

Backup files are created automatically and are saved in the same file
folder as your normal MuseScore file. The backup file adds a period to
the beginning of the file name (.) and a comma (,) to the end (for example
if your normal file is called "untitled.mscz", then the backup copy is
called ".untitled.mscz,"). The backup copy contains the previously
saved version of the MuseScore file and it can be important if your
normal copy becomes corrupted or you need to look at a slightly older
version version of your score. To open a MuseScore backup file you need
to rename the file by removing the period and comma. Since it is stored
in the same folder as your normal MuseScore file you also need to give it
a unique name (for example you might change the file name
".untitled.mscz," to "untitled-backup1.mscz").

http://musescore.com?utm_source=handbook


16

If you are using Linux then you will need to you need to change your
view settings to "show hidden files" in order to see the MuseScore
backup files.

Print and read (Export only)

PDF (*.pdf)

Portable Document Format (PDF) is ideal for sharing your sheet music
with others who do not need to edit the music. Most computer users
already have a PDF viewer on their computer so they will not need to
install any extra software to see your score.

PostScript (*.ps)

PostScript (PS) is popular as a page description language used in
professional printing.

PNG (*.png)

Portable Network Graphics (PNG) is a bitmap image format widely
supported by software on Windows, Mac OS, and Linux. The image
format is particularly popular on the web. Multi-page scores export a
PNG file for every page. MuseScore creates images as they would appear
on the printed page. If you want to create images that show screen-only
items such as frame boxes, invisible notes, and out-of-range note colors
then go to Edit → Preferences... (Mac: MuseScore → Preferences...) click on the
Export tab and mark "Screen shot function" check box.

SVG (*.svg)

Scalable Vector Graphics (SVG) can be opened by most web browsers
(except Internet Explorer) and most vector graphics software. However
most SVG software does not support embedded fonts so the appropriate
MuseScore fonts must be installed to view these files correctly.

Listen (Export only)

WAV Audio (*.wav)

WAV (Waveform Audio Format) is an uncompressed sound format
developed by Microsoft and IBM but widely supported by software for
Windows, Mac OS, and Linux. This is an ideal format for creating CDs
since no sound quality is lost in the process of saving the file. However
the large file sizes make it difficult to share via email or the web. This
export option is available in version 0.9.5 or later.

FLAC Audio (*.flac)
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Free Lossless Audio Codec (FLAC) is compressed audio format. FLAC
files are approximately half the size of uncompressed audio and just as
good quality. Windows and Mac OS do not have built-in support for FLAC
but software such as VLC media player can play FLAC files on any
operating system. This export option is available in version 0.9.5 or later.

Ogg Vorbis (*.ogg)

Ogg Vorbis is intended as a patent-free replacement for the popular MP3
audio format. Like MP3, Ogg Vorbis files are relatively small (often a
tenth of uncompressed audio) but some sound quality is lost. Windows
and Mac OS do not have built-in support for Ogg Vorbis. However
software such as VLC media player and Firefox 3.5 or later can play Ogg
files on any operating system. This export option is available in version
0.9.5 or later.

Share with other music software

MusicXML (*.xml)

MusicXML is the universal standard for sheet music and can be used by
most of the currently available scorewriters including Sibelius, Finale,
and more than 100 others. It is the recommended format for sharing
your sheet music between different scorewriters.

Compressed MusicXML (*.mxl)

Compressed MusicXML creates smaller files than regular MusicXML.
Compressed MusicXML is a newer standard and not as widely supported
by other scorewriters at this time.

MIDI (*.mid, *.midi, *.kar)

Musical Instrument Digital Interface (MIDI) is a format widely supported
by sequencers and music notation software. However MIDI files are
designed for playback not score layout so they do not contain information
about formatting, pitch spelling, voicing, ornaments, articulations,
repeats, or key signatures, among other things. To share files between
different music notation software use MusicXML. If all you care about is
playback then use MIDI.

LilyPond (*.ly) (Export only)

LY files can be opened by Lilypond, a free scorewriter. However LilyPond
export is incomplete and experimental in the current versions of
MuseScore.

MuseData (*.md) (Import only)

http://www.videolan.org/vlc/
http://www.videolan.org/vlc/
http://www.recordare.com/xml.html
http://lilypond.org
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MuseData is a format developed by Walter B. Hewlett beginning in 1983
as an early means of sharing music notation between software. It has
since been eclipsed by MusicXML but several thousand scores in this
format are still available on the web.

Capella (*.cap) (Import only)

CAP files are created by the scorewriter, Capella. MuseScore imports
these files fairly accurately.

Bagpipe Music Writer (*.bww) (Import only)

BWW files are created by the niche scorewriter, Bagpipe Music Writer.
This import option is available in versions 1.0 and later.

BB (*.mgu, *.sgu) (Import only)

BB files are created by the music arranging software, Band-in-a-Box.
MuseScore includes experimental support for BB import.

Overture (*.ove) (Import only)

OVE files are created by the scorewriter, Overture. This experimental
import option is available in versions 0.9.6 and later.

Share scores online
You can save and share your scores online at MuseScore.com. You can
choose to save a score privately for personal access from any computer, or
choose to share the score publicly for friends and band members to view or
download. MuseScore.com lets you view and playback scores in your web
browser and even lets you synchronize your score with a YouTube video. For
use outside of the web browser you can download the score in a variety of
formats (including PDF, MIDI, MP3, MusicXML, and the original MuseScore
file).

Create an account
1. Visit MuseScore.com and click on Create new account

2. Pick a username and enter a valid email and press "Create New
Account"

3. Wait a few minutes for an email from MuseScore.com support. If no
email arrived, check your spam folder

4. Click the link in the email and visit your user profile to change your
password

Share a score directly from MuseScore

http://musescore.com/?utm_source=handbook
http://musescore.com/user/register?utm_source=handbook
http://musescore.com/user?utm_source=handbook
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You can directly save a score online from File → Save Online.... If it's the first
time you are using this feature, you'll have to authenticate.

First time authentication

1. Go to File → Save Online...

2. MuseScore asks you to click OK to open your browser and gives
permission to MuseScore on MuseScore.com.

3. Click OK and your browser opens on MuseScore.com. If you are not
logged in, enter your username and password and

4. Click "Allow Access"

5. Go back to MuseScore, and press "OK". If your browser didn't open you
can copy paste the URL into your browser address bar.

6. MuseScore is now linked to your account on MuseScore.com

Save online
After your first authentication or when you go to File → Save Online..., 
MuseScore asks you some information about your scores

http://musescore.com/?utm_source=handbook
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1. The title is the title of the score. You can change it

2. The description will end up next to your scores. You can describe it,
say why you wrote it etc...

3. You can choose to make your score public and everybody on
MuseScore.com will see it or private and only you will be able to see the
score.

4. Choose a license. By using a Creative Commons licence, you let people
using your scores under some restrictions.

5. You can add tags to help finding your scores on MuseScore.com. Don't
forget to use a comma to separate the tags

Upload a score on MuseScore.com
You can also upload a score directly on MuseScore.com.

1. Click the Upload link on MuseScore.com

2. You have the same options as with the Save Online menu

3. You have also access to more information such as Genre

Edit a score on MuseScore.com
If you want to make changes to one of your scores on MuseScore.com, edit
the MuseScore file on your own computer and then follow the steps below.

1. Go to the score page on MuseScore.com

2. Click the edit link

3. In the form, you can change the score file, you can also change all the
score info such as title, description etc...

http://creativecommons.org
http://musescore.com/upload?utm_source=handbook
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Chapter 3

Notation

In the previous "Basics" chapter you learn how to enter notes and interact
with the palette. The "Notation" chapter describes the different types of
notation in more detail including more advanced music notation.

Accidental
Accidentals can be set or changed by dragging an accidental symbol from
the accidental palette to a note in the score.

If you only want to change the pitch of a note you can also select the note
and press:

• Up: Increase the pitch of a note by one semitone (favors sharps).

• Down: Decrease the pitch of a note by one semitone (favors flats).

• Ctrl+Up: Increase the pitch of a note by one octave.

• Ctrl+Down: Decrease the pitch of a note by one octave.

In version 0.9.6 or later you can change an existing accidental into a
cautionary accidental (enclosed in parentheses), drag the parentheses from
the accidental palette onto to the existing accidental (not the note head). To
remove parentheses select the accidental and press Delete.
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If you later change the pitch with cursor keys, manual settings to the
accidental are removed.

The menu function Notes → Pitch spell tries to guess the right accidentals for
the whole score.

Arpeggio and Glissando
Arpeggios are set by dragging an arpeggio symbol from the Arpeggio &
Glissando palette to a note of a chord.

In version 0.9.5 or later you can edit the length of the arpeggio by double
clicking on it and dragging the handle up or down.

Glissandos are set by dragging a glissando symbol from the Arpeggio &
Glissando palette to the first note of two consecutive notes on the same staff.

Bar line

Change bar line type
Bar lines are changed by dragging a bar line symbol from the bar line palette
to a bar line in the score.

To hide a bar line entirely right-click on the line and choose Set Invisible.
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Create grand staff
To extend bar lines over multiple staves double click on a bar line to edit it
(see Edit mode).

Click and drag the blue square down to the next staff.
Display of all staff bar lines updates when you leave edit mode.

See also: Measure operations

Beam
Beams are set automatically but the automatic setting can be overridden
manually. Drag a beam symbol from the beam palette to a note in order to
change its beam behavior.

You can also first select a note and then double click the appropriate symbol
in the beam palette.

Start a beam at this note.
Do not end a beam at this note.
Do not beam this note.
Start a second level beam at this note (not yet implemented in current

versions of MuseScore).

See also
• Cross staff beaming

Bracket

Delete
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Select the bracket and press Del

Add
Drag a bracket symbol from the bracket palette to an empty space in the first
measure of a system.

Change
Drag a bracket symbol from the bracket palette to an bracket in the score.

Edit
Double click on a bracket to enter edit mode. In edit mode you can drag the
height of a bracket to span arbitrary staves of a system.

Horizontal offset
If you need to move a bracket further left or right then double click the
bracket to enter edit mode, and press Shift+Left or Shift+Right.

Breath and pause
To place a breath symbol drag it from the breath palette to a note in the
score. The breath symbol is placed after the note. In versions 0.9.5 and
earlier the breath symbol appears before the note it was dragged to.

Breath symbol in score:

Caesura (informally called tram lines or railroad tracks) work the same
way and are available in versions 0.9.6 or later.
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Clef
Clefs are created or changed by dragging a clef symbol from the clef palette
to a measure or another clef. Use F9 (Mac: ⌥+⌘+K) to show or hide the
palette sidebar.

Add
Drag a clef from the palette onto an empty part of a measure. This creates a
clef at the beginning of the measure. Drag a clef to a particular note to
create a mid-measure clef. If the measure is not the first measure in the staff
it is drawn smaller.

Remove
Select a clef and press Del.

Note that changing a clef does not change the pitch of any note. Instead the
notes move to preserve pitch.

Drum notation
Example drum notation:

Notation for drumsets often include upstem and downstem notes happening
simultaneously. If are unfamiliar with editing multiple voices in a single staff
then see voices for an overview. See below for instructions specific to
percussion notation.
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MIDI keyboard
The easiest way to add drum notation to your score is via MIDI keyboard.
Most MIDI keyboard have percussion markings above each key. If you press
the key for high hat then MuseScore will add the correct notation to the
score. MuseScore automatically takes care of the stem direction and type of
note head.

Computer keyboard
Only a few drum-instruments are mapped to shortcut by default. You can add
more with right click on the staff → Edit drumset...

• c for Bass-Drum

• d for Ride

Mouse
Note entry for unpitched percussion works differently than for other
instruments, so here are the special steps:

1. Select a note or rest in the percussion staff. Please note that the Drum
palette will remain empty until you have completed this step

2. Press "N" to begin note entry

3. Select a note duration from the Note Input toolbar

4. Select a type of note (such as bass drum or snare) from the drum
palette

5. Click on the percussion staff to add the note to the score

External links
• Drum Parts [video]

Grace note
Short grace notes (Acciaccatura) appear as small notes with a stroke
through the stem. Long grace notes (Appoggiatura) have no stroke. Both
are placed before the normal-sized main note.

Instructions
Create a grace note by dragging a grace note symbol from the Grace Notes
palette (In versions 0.9.5 and earlier the palette is simply called Notes) to a
regular note on the score. It's also possible to create a grace note by
selecting a notehead and double clicking a grace note symbol from the Grace
Notes palette.

http://www.youtube.com/watch?v=kfj7v5s4akw
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To add more than one grace note, drag successive grace notes on the
notehead.

To add a chord of grace notes, enter the first one and select it, then use
Shift+ note names (C, D, E etc...)

If you want to change the duration of a previously created grace note, select
it and choose a duration from the toolbar or enter with one of the keys 1 ... 9
(see Note Entry).

External links
• Grace note, Appoggiatura, and Acciaccatura at en.wikipedia.org

Hairpin
Hairpins are line objects. To create a hairpin first select a note to mark the
start point.

• H: Creates a crescendo hairpin

• Shift+H: Creates a diminuendo hairpin (decrescendo)

You can also create hairpins by dragging a hairpin symbol from the line
palette to a note head.

1. H creates a crescendo hairpin:

2. Double click switches to edit mode:

3. Shift+Right moves end anchor:

4. Right moves end point:

http://en.wikipedia.org/wiki/grace_note
http://en.wikipedia.org/wiki/appoggiatura
http://en.wikipedia.org/wiki/acciaccatura
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Key signature
Key signatures are created or changed by dragging a key symbol from the
key palette to a measure or existing key signature.

F9 (Mac: ⌥+⌘+K) toggles the palette window.

Change
Drag a key from the palette onto a key in the score.

Add
Drag a key from the palette onto an empty part of a measure. This creates a
key at the beginning of the measure.

Remove
Select a key and press Del.

Line
The lines palette like other palettes works via "drag-and-drop". Use the
mouse to drag the item from the palette and drop it onto the score.

Change length
If you change the length of a line using the mouse then the anchor positions
(the notes or measures they apply to) do not change. Therefore the following
method is recommended for adjusting the start or end points of a line.
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1. If you are in note entry mode then press N to leave note entry

2. Double click the line that you want to change

3. Move the handles using the following shortcuts

• Shift+Right to move the anchor right by one note (or measure)

• Shift+Left to move the anchor left by one note (or measure)

4. If you need to change the length visually without changing the notes or
measures that the line is anchored to then use the following shortcuts

• Right to move the handle right by one unit

• Left to move the anchor left by one unit

See also: Hairpin, Volta (1st and 2nd endings)

Measure rests

Full-measure rest

When an entire measure is devoid of notes, a full-measure (full-bar) rest is
used.

To create a one-bar rest select a measure and press Del. All notes and rests
on this measure are then replaced by a one-bar rest.

Multi-measure rest

Multi-measure (multi-bar) rests indicate a long duration of silence for an
instrument and are frequently used in ensemble sheet music.

Instructions

1. From the menu choose Style → Edit General Style (in versions 0.9.5 and
earlier it is called Style → Edit Style)

2. Click on the "Score" tab if it is not already selected

3. Add a check mark next to "Create Multi Measure Rests"

Limitations
The style option automatically creates multi-measure rests throughout the
score. Therefore it is recommended that you enter all your notes first and
then turn on multi-measure rests afterward.
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Versions 0.9.5 and earlier do not automatically break multi-measure rests at
important points such as double bar lines, key signatures, rehearsal marks.
This is fixed for the latest versions of MuseScore. As a workaround for
earlier versions see the "Break multi-measure rests" heading of measure
operations.

Repeat
The start and end of simple repeats can be defined by setting appropriate
bar lines. For instructions on first and second ending measures see volta.

Playback

To hear repeats during playback make sure the "Play Repeats"  button on
the toolbar is selected. Likewise you can turn off repeats during playback by
deselecting the button.

In the last measure of a repeat you can set the property "Repeat Count" to
define the number of played repeats.

Repeat Symbols and Text
Text and symbols related to repeats are located in the Repeats palette:

To add an object from the Repeats palette, drag it onto (not above) the
measure where you want it to occur. The object then appears above that
measure in your score.

Slur
A slur is a curved line between two or more notes that indicates they are to
be played without separation. If you mean to join two notes of the same
pitch, see Tie

Instructions
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1. Leave note entry mode and select the first note:

2. S creates a slur:

3. Shift+Right moves the slur end to the next note:

4. X flips the slur direction:

5. Escape ends Slur Edit mode:

Adjustments
The boxes or handles (displayed in the images for steps 2-4 above) can be
adjusted with the mouse. The two outer handles adjust the start and end of
the slur. The two inner handles adjust the contour of the slur.

A slur can span several systems and pages. The start and end of a slur is
anchored to a note/chord or rest. If the notes are repositioned due to
changes in the layout, stretch or style, the slur also moves and adjusts in
size.

This example shows a slur that spans from the bass to the treble clef. Using
the mouse, select the first note of the slur, hold down the Ctrl key and select
the last note for the slur, and press S to add the slur.
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Note: It is not possible to change the start and end anchor notes using the
mouse. Use Shift + left or right arrow keys to adjust the start and end points
of a slur.

Dotted line
Dotted slurs are sometimes used in songs where the presence of a slur varies
between stanzas. Dotted slurs are also used to indicate an editor's
suggestion (as opposed to the composers original markings). To change an
existing slur into a dotted slur right-click on it and choose Slur Properties....
From the Slur Properties dialog you can choose whether you want a solid or
a dotted slur.

See also: Tie, Edit mode.

Attachment Size
slur_b2t.png 12.16 KB

Tie
A tie is a curved line between two notes of the same pitch. If you want a
curved line that spans multiple pitches see Slur.

First method
Select first note:

+ creates a tie:

Second method
To create ties during note entry press + after the first note of the tie.

Time signature
Time signatures are available in the main palette sidebar. You can drag
and drop the times signatures onto the score (see palette for general
information on working with palettes in MuseScore).

http://musescore.org/sites/musescore.org/files/slur_b2t.png
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If you need a time signature not found in the sidebar palette then go to Create
→ Time... to create your own. You can edit the upper and lower numbers in
the Create Time Signature pane.

In most cases you'll only need to edit the first of the upper numbers. The
additional upper numbers are for additive meters which contain multiple
upper numbers separated by a plus sign.

Pickup measures
There are occasions when the actual duration of a measure is different from
the duration specified by the time signature. Pickup measures are a common
example. To change the actual duration of a measure without displaying a
different time signature see the Properties section of measure operations.

Tremolo
Tremolo is the rapid repetition of one note or a rapid alternation between
two or more notes. It is indicated by strokes through the stems of the notes.
If the tremolo is between two or more notes, the bars are drawn between
them.

The tremolo palette contains separate symbols for one note tremolos (shown
with stems below) and for two note tremolos (shown with no stem below).

http://en.wikipedia.org/wiki/time_signature#additive_meters
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In a two note tremolo every note has the value of the whole tremolo duration.
To enter a tremolo with the duration of a half note (minim) first enter two
normal quarter notes (crotchets). After dragging a tremolo symbol to the
first note the note values automatically double to half notes.

Tuplet
Tuplets are used to write rhythms beyond the beat divisions usually
permitted by the time signature. For example, triplet eighth notes (quavers)
in a 4-4 time signature divide the quarter note (crotchet) beat into three
instead of two.

Instructions
To create a triplet first select a note on the score that specifies the full
duration of the triplet group. For example, a group of triplet eighth notes
(quavers) has a "full duration" of one quarter note (crotchet).

From the main menu choose Notes → Tuplets → Triplet. This creates a triplet by
dividing the full duration into three equal parts,

which can be further edited.

Note entry mode
Tuplet entry works a little differently in note entry mode than the method
outlined above. In version 0.9.5 or later you must select duration first then
enter the pitches afterward. Below are step-by-step instructions for making
triplet eighth notes.

1. Switch to note entry mode by pressing N

2. Make sure the note entry marker is in the place that you want to start
the tuplet (use the right and left arrow keys if necessary)

3. Choose the duration for the whole tuplet group from the note entry
toolbar. For this example click on the quarter note (or press 5 on the
keyboard)

4. From the main menu choose Notes → Tuplets → Triplet, or press Ctrl+3

(Mac: ⌘+3)

5. Notice that an eighth note duration is automatically selected. Click on
the staff to add pitches
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Properties
To change the display properties of a tuplet right click on the tuplet number
and choose Tuplet Properties....

The number section of the properties dialog allows you to show one integer,
a ratio of two integers, or no number at all.

In the bracket section the "bracket" and "nothing" allow you to explicitly
show or hide the bracket. The "auto bracket" option hides the bracket for
beamed notes and shows the bracket if the tuplet includes unbeamed notes
or rests.

External links
• Tuplet at Wikipedia

• How To Create Triplets in MuseScore [video]

Voices
Voices allow you to have notes on a single staff which start at the same time
yet have different durations. Voices are sometimes called 'layers' in other
notation software.

Instructions
1. First start by entering the top voice (all the up-stem notes). When you 

enter the notes some may have down-stems. You do not need to worry 
about the stem direction at this point because they will flip automatically 
when you add the second voice.

http://en.wikipedia.org/wiki/tuplet
http://www.musescoretips.com/2011/02/how-to-create-triplets-in-musescore-video/
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2. If you are using a computer or MIDI keyboard to enter notes (instead of
the mouse), use the Left arrow key to move your cursor back to the
beginning.

3. Click on "Voice 2" button 

4. Enter all the bottom voice notes (all the down-stem notes). When you
are done it should look like this:

When to use voices
• If you need stems pointing in opposite directions within a chord on a

single staff

• If you need notes of different durations within a single staff, played
simultaneously

Hidden spacer rests
To hide a rest right-click on the rest and select Set Invisible. If you have Display
→ Show Invisible marked then the rest still shows in gray on your screen. The
hidden rest does not appear when you print.

Volta
Volta brackets or first and second ending brackets are used to mark
different endings for a repeat.

To place a volta bracket on the score drag-and-drop the item from the lines
palette.

The brackets can span more than one measure. Double click the volta to
enter edit mode and then move the handles with:

• one measure right Shift+Right

• one measure left Shift+Left

These commands move the "logical" start or end of the volta bracket which
determines playback in MuseScore and layout over multiple systems. Moving
the handles using the left or right arrows keys only or using the mouse
allows finer adjustments but does not change how the repeat is played.
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If you move the handles, a dashed line from the logical position to the actual
position is shown

Text
You can change the text and many other properties of a volta bracket using
the Line Properties dialog. Right-click on a volta bracket and choose Line
Properties.... The figure below shows the volta text as "1.-5."

You can also right-click on the Volta and bring up the Volta Properties dialog.
From here you can change both the displayed Volta text (the same from the
Line Properties above) and the Repeat List. If you want one volta to be
played only on certain repeats and another volta on other repeats, enter the
repeat times in a comma separated list. In the example below, this volta will
be played during repeat 1, 2, 4, 5 and 7. Another volta will have the other
ending, like 3, 6 and possibly other higher numbers like 8, 9, etc.

Playback
Sometimes a repeat plays for more than two times. In the figure above the 
volta text indicates that it should play five times before it continues. If you
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want to change the number of times MuseScore plays a repeat then go to the
measure containing the repeat bar line and change its Repeat Count (see
Measure operations for details).

In version 0.9.4 or earlier you can only place voltas on the top staff of a
multi-part score. Otherwise you may encounter bugs such as the MuseScore
crashing when you create parts (see bug report) or the anchor position
moving when you reload the score.

External links
• Screencast: Add alternative repeats with MuseScore 0.9.5

http://www.musescore.org/en/node/1257
http://www.youtube.com/watch?v=jwizibuf_j8
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Chapter 4

Sound and playback

MuseScore has "Sound and playback" capabilities built in. This chapter
covers the playback controls and ways to extend the instrument sounds
beyond the built-in piano sound.

Play mode
MuseScore has an integrated sequencer and synthesizer to play your score.

By pressing the Play  button you enter Play mode. In Play mode the
following commands are available:

• Seek to previous chord Left

• Seek to next chord Right

• Seek to previous measure Ctrl+Left (Mac: Left)

• Seek to next measure Ctrl+Right (Mac: Right)

• Rewind to start of score Home (Mac: ⌘+Home)

• Toggle show play panel F11 (Mac: ⌥+⌘+P)

Press the play button again to stop and exit Play mode.

MuseScore starts playback from the place it last left off. If you select a note
then MuseScore starts from the newly selected note instead. The toolbar also
has rewind button to quickly return to the beginning of the score for
playback.

Play Panel
The Play Panel offers more controls over playback including tempo, starting
position, and general volume. From the main menu choose Display → Play Panel
to open the Play Panel.
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Troubleshooting
Version 0.9.5 or earlier: If you want to play instruments other than piano
you have to change the MuseScore integrated SoundFont with a more
capable one in Edit → Preferences... → I/O tab. See SoundFont for instructions.

Sound on Ubuntu
If you are having difficulty with sound on Ubuntu then it is recommended to
upgrade to version 0.9.5 or later. Instructions for obtaining the latest release
are on the download page of the website. If you have further problems feel
free to use the forums.

SoundFont
MuseScore comes with a special type of file called a SoundFont that tells
MuseScore how to play each instrument sound. Some SoundFonts are
custom designed for classical music others for jazz or pop, others are large
and take up a lot of memory, still others are very small and light-weight. The
latest versions of MuseScore (version 0.9.6 or higher) come with a relatively
light-weight, general-purpose SoundFont called, "TimGM6mb.sf2".

Overview
A SoundFont file can store any number of instrument sounds. Many
SoundFonts are available on the web. Look for one that covers the 128
sounds of General MIDI (GM). If you use a SoundFont that does not conform
to the General MIDI standard then others may not hear the correct
instruments when you share the score or save as MIDI.

The file size and sound quality of SoundFonts available on the web varies.
Larger SoundFonts often sound better but may be too large to run on your
computer. If you find MuseScore runs slowly after installing a large
SoundFont or your computer can't keep up during play back then look for a
smaller SoundFont. Below are three popular GM SoundFonts of different
sizes.

• FluidR3_GM.sf2 (141 MB uncompressed)
Download Fluid-soundfont.tar.gz

http://en.wikipedia.org/wiki/general_midi
http://www.musescore.org/download/fluid-soundfont.tar.gz
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• GeneralUser_GS_1.43-MuseScore.sf2 (29.8 MB uncompressed)
Download GeneralUser_GS_1.43-MuseScore.zip (Courtesy of S. Christian
Collins)

• TimGM6mb.sf2 (5.7 MB uncompressed)
Download modified TimGM6mb.sf2 (Courtesy of Tim Brechbill)

Compression
Since SoundFont files are large they often are compressed into a variety of
formats including .zip, .sfArk, and .tar.gz. You need to decompress these files
before they can be used.

• ZIP is standard compression format supported by most operating
systems.

• sfArk is a compression format designed especially for compressing
SoundFont files. Use the special sfArk software to decompress it.

• .tar.gz is a popular compression format for Linux. Windows users can
use 7-zip which supports a wide variety of compression formats. Note
that you need apply decompression twice: once for GZip and once for
TAR.

MuseScore settings
After finding and decompressing a SoundFont do not double click to open it
since this does not set up MuseScore. Instead move the file to a folder of
your choosing, start MuseScore, and follow the instructions below.

Go to Display → Synthesizer. The initial SoundFont setting depends on which
operating system you are using.

• Windows: C:/Program Files/MuseScore//sound/TimGM6mb.sf2

• Windows (64-bit): C:/Program Files
(x86)/MuseScore//sound/TimGM6mb.sf2

• Mac OS X:
/Applications/MuseScore.app/Contents/Resources/sound/TimGM6mb.sf2

• Linux (Ubuntu): /usr/share/sounds/sf2/TimGM6mb.sf2

Click on the Open icon next to the SoundFont location and browse for your
new SoundFont (.sf2) file. In the open dialog browse and select your file;
then press Open.

Instructions for 0.9.5 or earlier
If you are using version 0.9.5 or earlier then go to Edit → Preferences... → I/O
tab.

The initial SoundFont setting is :/data/piano1.sf2. Replace this with the 
location of your new SoundFont (.sf2) file. Click on the Open icon to browse

http://www.schristiancollins.com/soundfonts/generaluser_gs_1.43-musescore.zip
http://www.schristiancollins.com/generaluser.php
http://www.schristiancollins.com/generaluser.php
http://mscore.svn.sourceforge.net/viewvc/mscore/trunk/mscore/share/sound/timgm6mb.sf2
http://ocmnet.com/saxguru/timidity.htm#sf2
http://www.melodymachine.com/sfark.htm
http://www.7-zip.org/
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for the file and open it .

Click OK to apply changes and exit the preferences panel. Quit and and
reopen MuseScore for the changes to take affect.

Troubleshooting
If the toolbar play panel is greyed out or not visible follow the instructions
below to get your sound working again:

1. Make sure there is a check mark next to the Display → Transport menu
item. You can add or remove the check mark by clicking on the
corresponding menu item. If this step does not solve your problem
continue with the next step below

2. If the play panel disappears after changing the SoundFont go to Edit →
Preferences... → I/O tab and click OK without making any changes, After
restarting MuseScore the play panel should reappear. This is a known
bug with versions 0.9.3 or earlier.

If you are setting up a SoundFont for the first time please use one of the
recommended SoundFonts listed above.

If playback stutters then you computer is not able to handle the SoundFont
you are using. Two solutions:

1. Reduce the amount of RAM (memory) used by MuseScore by using a
smaller SoundFont. See list above for suggestions

2. Increase the amount of RAM available for MuseScore by quitting all
applications except MuseScore. If you still have problems and a large
SoundFont is important to you then consider purchasing more RAM for
your computer

Tempo
Play back tempo can be changed via the play panel or via tempo text in the
score.

Play panel
• Display the play panel: Display → Play Panel

• Change the Beats per Minute (bpm) using the Tempo (Tmp) slider

Tempo text
• Select a note to indicate where the tempo text should be created

• From the main menu: Create → Text... → Tempo...

• Press OK to finish
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Existing tempo text can be changed by double clicking the text to enter edit
mode. You can use Text Symbols to add a quarter note or another duration
for a metronome mark in the tempo text.

Beats per minute (BPM) on existing tempo text can be adjusted by right
clicking on the text and selecting Tempo Properties...

Note: Playback of tempo text may be faster or slower than the specified BPM
if the tempo setting in the play panel is not set to 100 percent.

Change and adjust sounds

Mixer
The mixer allows you to change instrument sounds and adjust the volume,
panning, reverberation, and chorus for each staff. From the main menu
choose Display → Mixer to show the mixer.

Mute and Solo
Use the Mute check box to quickly silence certain staves. Alternatively use
the Solo check box to silence all staves except the staff you mark as "solo".

Dials
To turn a dials clockwise click and drag upwards. To turn a dial
counter-clockwise (anti-clockwise) click and drag downwards.

Sound
The sound drop-down menu lists every instrument supported by your current
SoundFont. This feature is not implemented in version 0.9.4 or earlier for
Windows, but fixed in version 0.9.5.

Change instrument
Although you can change the instrument sound, staff name, and staff
transposition separately, versions 0.9.6 or later allow you to change all of
these properties at once.

1. Right click on an empty part of the measure and choose Staff Properties...

2. Click on Change Instrument

3. Choose your new instrument and click OK to return to the Staff
Properties dialog
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4. Click OK again to return to the score

Mid-staff change
In MuseScore some instruments can change sounds midway through a piece.
For example strings can switch to pizzicato or tremolo and trumpet can
switch to muted trumpet. The following instructions use muted trumpet as
an example but the same principles apply to pizzicato or tremolo strings.

1. Select the first note of the muted section

2. From the main menu choose Create → Text → Staff Text

3. Type Mute (or an equivalent indication such as Con Sordino). At this point
the staff text is for humans and does not affect playback in MuseScore

4. Right-click on the staff text and select Staff Text Properties...

5. In the Staff Text Properties dialog mark the Channel checkbox

6. In the Staff Text Properties dialog select mute

7. Click OK to return to the score

Every note after the staff text you added now sounds muted. To return to an
unmuted sound later in the piece follow the same guidelines as above except
type Open in step 3 and select normal in step 6.

Dynamics
Playback volume can be changed for the entire piece by the play panel, or
locally by Dynamics text in the score.

Play panel
• Display the play panel: Display → Play Panel

• Change the Volume using the slider

Dynamics text
From the Dynamics palette, click and drag a Dynamics text to a measure in
the score.

Adjusting playback volume for a Dynamics text

• Right click on the Dynamics text to open the menu.

• Select "MIDI Properties".

• Adjust the "Velocity" number, higher for louder, lower for softer.



45

Chapter 5

Text

The previous chapter covers text that affects playback tempo, but there are
many other types of text available in MuseScore: lyrics, chord names,
dynamic markings, fingering, headings, plus many more. These are all
accessible from the main menu via Create → Text.

For short generic text use staff or system text. The difference between these
two texts is whether you want it to apply to a single staff or apply to the
whole system.

Text editing
Double click on text to enter edit mode:

In text edit mode the following commands are available:

• Ctrl+B (Mac: ⌘+B) toggles bold face

• Ctrl+I (Mac: ⌘+I) toggles italic

• Ctrl+U (Mac: ⌘+U) toggles underline

• move cursor: Home End Left Right

• Backspace remove character to the left of the cursor

• Delete remove character to the right of the cursor

• Return start new line

• F2 Insert text symbol (see below)

Symbols and special characters
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You can use Text Symbols to insert quarter notes, fractions, and other
special symbols or characters into your text. In the text toolbar click on the
keyboard icon  to open the Text Symbols palette

See also: Chord name, Lyrics, Frame, Edit mode

Text style
Each text type has a basic style. For example, title text is centered and uses
a large font size, Composer text is smaller and aligned to the right. To edit
text styles go to Style → Edit Text Style....

During text editing, you can make changes that depart from basic style. For
details see "Formatting existing text" below.

Text properties:
• Font: name of the font such as "Times New Roman" or "Arial"

• Size: the size of the font in points

• Italic, Bold, Underline: font properties

• Anchor: page, time, notehead, system, staff

• Alignment: horizontal: left, right, center; vertical: top, bottom, center

• Offset: an offset to the normal anchor position

• Offset Type: mm, space, or percent of page size

Text types:
• Title, Subtitle, Composer, Poet: anchored to page

• Fingering: Fingerings are anchored to note heads.

• Lyrics: Lyrics are anchored to a time position.

• Chord name: Chord names are also anchored to a time position.

• System: Applies to all staves in a system.* Anchored to a time position.

• Staff: Applies to a single staff in a system.* Anchored to a time position.
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* The distinction between System and Staff text matters for ensemble scores.
System text will extract to all parts. Staff text will only extract to the part to
which it is anchored.

Formatting existing text
In MuseScore 1.0 and earlier, text style changes apply to new text but do not
consistently change existing text. However, you can change the formatting of
existing text by right-clicking and choosing "Text properties". To apply your
changes to all text of the same type, check the box "apply to all elements of
the same type".

Chord name
Chord names can be entered by first selecting a note and then pressing
Ctrl+K (Mac: ⌘+K). This creates a chord name text object for the selected
chord.

• Type Space to move to the next chord (or beat in versions 1.1 and later)

• Shift+Space moves to the previous chord (or beat in versions 1.1 and later)

• Type Tab to move to the next measure (versions 1.1 and later).

• Shift+Tab moves to the previous measure (versions 1.1 and later)

Chord names can be edited as normal text. To add a sharp type # and to add
a flat type b. These characters will automatically turn into proper sharp or
flat signs when you move to the next chord.

MuseJazz font
If you prefer a more handwritten appearance to the chord names in your
score, then versions 0.9.5 and later include a font option called "MuseJazz".

To use this font in version 1.1 or later:

1. From the main menu choose Style → Load Style...

2. Navigate to the styles folder if necessary

3. Select MuseJazz.mss

This will set up your score to use "MuseJazz" for most text, including chord
names. If you prefer to use "MuseJazz" for chord names only, or if you are
using version 1.0 or earlier, use the following procedure:

1. From the main menu choose Style → Edit General Style...

2. From the left pane select Chordnames
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3. In the right pane replace the text stdchords.xml with jazzchords.xml or one
of the following files.

In 1.1 and later, MuseScore provides several new alternatives for chord
name style in addition to jazzchords.xml that can be selected using the above
procedure. Here are the available styles:

• cchords_muse.xml (the default when using MuseJazz.mss):

• cchords_nrb.xml:

• cchords_rb.xml:

• cchords_sym.xml:

Attachment Size
cchords_muse.png 11.77 KB
cchords_nrb.png 12.55 KB
cchords_rb.png 11.28 KB
cchords_sym.png 11 KB

Fingering
Fingering can be added to notes by dragging a fingering character from the
fingering palette to a note head in the score. When a note head is selected
first, the fingering character can be added using a double click. Fingerings
are normal text which can be edited like any other text.

Lyrics

http://musescore.org/sites/musescore.org/files/cchords_muse_1.png
http://musescore.org/sites/musescore.org/files/cchords_nrb_1.png
http://musescore.org/sites/musescore.org/files/cchords_rb_1.png
http://musescore.org/sites/musescore.org/files/cchords_sym_1.png
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1. First enter notes

2. Select first note

3. From the main menu choose Create → Text → Lyrics and type the syllable
for the first note

4. Type Space at end of a word to go to the next note

5. Type an hyphen - at end of syllable to go to next note. The syllables are
connected with a dash

6. Shift+Space moves to the previous syllable

7. Enter (Mac: Return) moves down to the next lyric line

Syllables can be extended by an underline:

Entered with: soul, _ _ _ To Esc.

Special characters
Lyrics can be edited as normal text with the exception of a few characters. If
you want to add a space, hyphen or underscore to a single syllable then use
the following shortcuts.

• Ctrl+Space (Mac: ⌥+Space) enters a space into the lyrics text

• Ctrl+- (Mac: ⌥+-) enters a hyphen (-) into the lyrics text

• Mac only: ⌥+_ enters an underscore (_) into the lyrics text

See also: Text, Chord name.
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Chapter 6

Formatting

Break or spacer
Page breaks or line breaks (system breaks) are applied by dragging the
corresponding symbol from the breaks palette to an empty space of a
measure in the score. The break happens after the marked measure. The
green break symbols are visible on the screen but do not appear on
printouts.

Mid-measure system breaks are sometimes needed (especially for strophic
hymns or lieder). For example, if you want three beats on one system and a
one beat pickup on the next system, then you need to create two measures
with a shortened duration. For details see Measure operations, "Duration"
and "Irregular" sections.

Spacers are used to increase the space between two adjacent staves. Drag
and drop a spacer to a measure above the area that needs more vertical
space. Double click on the spacer and drag the handle using the mouse to
adjust the height of the spacer.

If you want to adjust the space between staves score-wide then use the style
settings. Spacers are designed for local adjustments.

Frame
Frames provide empty space outside of normal measures. They can also
contain text or pictures. MuseScore has two kinds of frames:

Horizontal
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Horizontal frames break a system. The width is adjustable and the height
equals the system height. Horizontal frames can be used to separate a
coda.

Vertical

Vertical frames provide empty space between or before systems. The
height is adjustable and the width equals the system width. Vertical
frames are used to place title, subtitle or composer. If you create a title,
a vertical frame is placed before the first measure automatically if it is
not there already.

Create a frame
First select a measure. The command to insert a frame is found in the menu
Create → Measures . The frame is inserted before the selected measure.

Delete a frame
Select the frame and press Del.

Edit frame
Double click the frame to enter edit mode. A handle appears which can be
used to drag the size of the frame.

Title frame in edit mode:
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Image
You can use images to illustrate scores or add symbols that are not included
in the standard palettes.

To add an image drag-and-drop an image file onto the score. MuseScore
supports PNG and JPEG files and simple SVG files. MuseScore does not
support SVG shading, blurring, clipping or masking.
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Chapter 7

Advanced topics

Cross staff beaming
In piano scores it is common to use both staves (bass and treble clef) to write
a musical phrase.
This can be entered in MuseScore as follows:

First enter all notes in one staff:

Ctrl+Shift+Down moves the selected note or chord to the next staff (Mac:
⌘+Shift+Down.)

See also: Bar line for cross-staff bar lines (i.e. grand staff).

Part extraction
If you have written a full ensemble score, MuseScore can create sheet music
that shows only the individual part for each musician in the ensemble.
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In current versions of MuseScore, the process of extracting parts from a full
score involves two main steps:

1. Specifying which instruments are included in each part ("Defining the
parts")

2. Actually creating the part

Defining the parts
You can define the parts at any point after creating a new score. You only
need to define the parts once for each score, but of course you can come
back and make changes if needed. The following instructions use a string
quartet as an example but the same principles apply for any other ensemble.

From the main menu choose File → Parts...

In the Parts window click New to create a "part definition"

In the right pane, type the words you want to use for the "File Name"
and "Part Title"

File Name

The initial name used when you save the part on your computer
(required)

Part Title
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The text printed on the first page of your part, top left corner
(optional)

4. Pick the instrument that you want to appear in your part by marking the
relevant box in the right-hand pane. Usually you only want one
instrument per part, but sometimes you might need a part that includes
more than one instrument (such as multiple percussion staves).
MuseScore lets you mark as many instruments per part as you need.

5. Repeat steps two through four (above) for each part as needed

6. Once you done, press Close to dismiss the Parts window

You have now finished defining the parts. You do not need to do this again
unless you add or remove an instrument from your full score. In current
versions of MuseScore it is not possible to split a single staff (that contains
two or more voices) into separate parts. So, any instrument that you want to
print out a separate part for also needs to have its own staff in the full score.
This may require some planning.

Creating the parts
You can create your parts at any time to see how they look, but it is only
necessary to do it after you have finished the full score and want to print out
the individual parts:

1. From the main menu choose File → Parts... to return to the Parts window.
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2. In the left pane, click to select a part that you want to create and view

3. Press Create Part and a new tab is added to the main MuseScore window
containing your newly created part

Repeat steps two and three for each part that you want to view or print. If
you make any changes to the full score you can re-create a part at any time
in order to show the new changes in the part.

Saving
In current versions of MuseScore changes on a score are not linked to parts
that have already been created, so any change you make on the score will
also need to be made on the individual part either manually or by recreating
the part from the steps above. Also, parts are created as not-yet-saved files,
so each part you just created needs to be saved as an individual file (via File →
Save...) or it will be lost when closing the tab. Usually you may want to review
it before saving to check for proper formatting.

Plugins
Plugins are small piece of code that add a particular feature to MuseScore.
By adding a plugin, a new menu will be appended to the Plugins menu in
MuseScore to accomplish a given action on the score or a part of it. Plugins
are a way to let users with minimal programming skills add features to the
software. To develop plugins, checkout the documentation.

Some plugins are already delivered with MuseScore. You can find more
plugins in the plugin repository.

Installation
Note that some plugins may require the installation of other components
(fonts...) to work . Read the plugin documentation for more information.

Windows
MuseScore looks for plugins in C:\Program Files\MuseScore\Plugins and
in C:\Users\USERNAME\AppData\Local\MusE\MuseScore\plugins on Vista
and Seven or C:\Documents and Settings\USERNAME\Local
Settings\Application Data\MusE\MuseScore\plugins on Windows XP.
Download the plugin zip file and uncompress it to one of these directories.

MacOS X
On MacOS X, MuseScore looks for plugins in the MuseScore bundle in
/Applications/MuseScore.app/Contents/Resources/plugins and in
~/Library/Application Support/MusE/MuseScore/plugins. Download an
unzip the plugin file in one of these directories.
To be able to move files in the app bundle, right click on MuseScore.app and
choose "Show package contents" to reveal the Contents directory.

http://musescore.org/en/plugin-development
http://musescore.org/en/plugins
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Linux
Download and unzip the plugin in /usr/local/share/mscore-1.0/plugins
or in~/.local/share/data/MusE/MuseScore/plugins

Plugin installed by default

ABC import
This plugin used a webservice (http://abc2xml.appspot.com/) to open an ABC
file in MuseScore. It supports ABC 1.6. The ABC file is sent to the
webservice, and a MusicXML file is returned. The plugin then display the
score as a new score.

Chord chart
This plugin creates a new score with all the chordnames supported by
MuseScore in Jazz style.

Color notes
This plugin colors the notehead of all notes in all staves and voices according
to the BoomWhackers convention. Each pitch has a different color. C and C#
have a different color. C# and Db have the same color.
To color all the notes in black, right click on a notehead -> Select -> All
similar elements. Right click again on the notehead -> Color -> Pick black.

Create scores
This plugin creates a new piano score with 4 quarters C D E F. It's a good
start to learn how to make a new score and add notes from a plugin.

Note names
This plugin displays the english name of each note of voice 1 close to the
notehead.

Test
This plugin is just a test and display a dialog box "Hello MuseScore". It's a
good base to start learning plugin development.

http://abc2xml.appspot.com/
http://en.wikipedia.org/wiki/abc_notation
http://en.wikipedia.org/wiki/abc_notation
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Chapter 8

Support

This chapter describes how to find help using MuseScore: the best places to
look, the best way to ask a question on the forums, and tips for reporting a
bug.

How to report bug or ask for support
Before posting your support request in the forum:

• PLEASE, look for a solution in the user handbook.

• Use the search function of the website to see if someone has already
encountered the same problem on the forums.

• If you are posting an error report, first try to reproduce the problem
with the latest prerelease. You may also view the version history to check
whether it has been fixed already.

When posting your request for support or bug report, please include as much
of the following information as you know:

• Version of MuseScore you are using (e.g. version 1.0) or the revision
number if you are using a prerelease (e.g. revision 3996)

• Operating system you are running it on (e.g. Windows Vista, Windows 7,
Mac OS 10.6 or Ubuntu 10.10)

• If you are reporting a bug, please describe the precise steps that lead to
the problem (where do you click, what keys do you press, what do you
see, etc.). If you are not able to reproduce the problem with the steps, it
is probably not worth reporting it as the developers will not be able to
reproduce it (and solve) either.

• Limit your reports in the issue tracker to one bug per report

• Remember that the goal of a bug report is not only to show the bug but
to allow others to reproduce the bug easily

http://musescore.org/en/forum
http://musescore.org/en/handbook
http://musescore.org/en/search
http://musescore.org/en/forum
http://musescore.org/en/download
http://mscore.svn.sourceforge.net/viewvc/mscore/trunk/mscore/changelog
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Known incompatibilities

Hardware incompatibilities
The following software is known to crash MuseScore on startup :

• Samson USB Microphone, driver name "Samson ASIO Driver",
samsonasiodriver.dll. More info

• Digidesign MME Refresh Service. More info

Software incompatibilities
• Maple virtual cable is known to prevent MuseScore to close properly.

• KDE (Linux) window settings can cause the whole window to move when
dragging a note. Changing the window settings of the operating system
avoids the problem.

Font problem on Mac OS X
MuseScore is known to display notes as square when some fonts are
damaged on MacOS X.
To troubleshoot this issue :

1. On your Mac, go to Applications -> Font Book

2. Select a font and press ⌘+A to select them all

3. Go to File -> Validate Fonts

4. If any font is reported as damaged or with minor problems, select it and
delete it

5. Restart MuseScore if necessary

Font problem on Linux
If the default desktop environment application font is set to bold, MuseScore
will not display the notes properly.
To troubleshoot this issue (gnome users):

1. Right-click on your desktop and select Change Desktop background

2. Click on Fonts tab

3. Set Regular style for Application font

4. Restart MuseScore if necessary

Save As dialog empty on Linux

http://musescore.org/en/node/6849
http://musescore.org/en/node/6529
http://musescore.org/node/1335
http://musescore.org/en/node/8318#comment-27683
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Some users reported that the Save As dialog is empty on Debian 6.0 and
Lubuntu 10.10.
To troubleshoot this issue :

1. Type the following in a terminal
which mscore

2. The command will answer with the path of mscore. Edit it with your
prefered text editor and add the following line at the beginning
export QT_NO_GLIB=1

Launch MuseScore and the problem should be solved.

Revert to factory settings
Recent versions of MuseScore have the option to revert back to the standard
built-in presets or "factory-settings". Sometimes this is helpful if your
settings are corrupted. This is not a normal occurrence so it is best to
consult the forums first since there maybe a way to solve your problem
without resetting everything.

Warning: reverting to "factory settings" removes any changes you have
made to the preferences, palettes, or window settings.

Instructions for Windows
1. If you have MuseScore open then you need to close it first (File → Quit)

2. Type Windows key+R to open the Run dialog. (The Windows key is the one
with the logo for Microsoft Windows.)

3. Click Browse...

4. Look for mscore.exe on your computer. The location may vary
depending on your installation but it is probably something similar to My
Computer > Local Disk > Program Files > MuseScore > bin >
mscore.exe

5. Click Open to leave the Browse dialog and return to the Run dialog. The
following text (or something similar) should display in the Run dialog:
"C:\Program Files\MuseScore\bin\mscore.exe"

6. Click after the quote and add a space followed by a hyphen and a
capital F: -F

7. Press OK

After a few seconds MuseScore should start and all the settings reverted to
"factory settings".

For advanced users, the main preference file is located at:

http://en.wikipedia.org/wiki/windows_key
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• Windows Vista or later:
C:\Users\<USERNAME>\AppData\Roaming\MusE\MuseScore.ini

• Windows XP or earlier: C:\Documents and
Settings\USERNAME\Application Data\MusE\MuseScore.ini

The other preferences (palette, session...) are in:

• Windows Vista or later:
C:\Users\<USERNAME>\AppData\Local\MusE\MuseScore\

• Windows XP or earlier: C:\Documents and Settings\USERNAME\Local
Settings\Application Data\MusE\

Instructions for Mac OS X
1. If you have MuseScore open then you need to quit the application first

(File → Quit)

2. From the Open Applications/Utilities/Terminal and a Terminal session
window should appear

3. Type, (or copy/paste) the following command into your terminal line
(include the '/' at the front):

/Applications/MuseScore.app/Contents/MacOS/mscore -F

This resets all MuseScore preferences to factory settings and immediately
launches the MuseScore application. You can now quit Terminal, and
continue using MuseScore.

For advanced users, the main preference file is located in
~/.config/muse.org/MuseScore.ini.
The other preferences (palette, session...) are in ~/Library/Application
Support/MusE/MuseScore/

Instructions for Linux (please adapt for flavors other than
Ubuntu)

1. If you have MuseScore open then you need to quit the application first
(File → Quit)

2. From the Ubuntu main menu choose Applications → Accessories → Terminal.
A Terminal session window should appear

3. Type, (or just copy/paste) the following command into your terminal
line:

mscore -F

This resets all MuseScore preferences to factory settings and immediately
launches the MuseScore application. You can now quit Terminal, and
continue using MuseScore.
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For advanced users, the main MuseScore preference file is located at
~/.config/MusE/MuseScore.ini

The other preferences (palette, session...) are in
~/.local/share/data/MusE/MuseScore/
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Chapter 9

Appendix

Glossary
The glossary is a work in progress, please help if you can. You can
discuss about this page on the documentation forum
The list below is a glossary of frequently used terms in MuseScore as well as
their meaning. Translators of this page, should be adding the translation for
each term.

Acciaccatura

A short grace note. See →grace note

Accidental

Accidentals appear in front of notes and shift their pitch.
Accidentals are used to alter the pitch of a note within a piece. The same
symbols as in the →key signature are used, but they are placed before a
particular note. Accidentals are for example sharps, flats and naturals.
Accidentals affect all notes on the same staff position for the remainder
of the measure in which they occur, but they can be canceled by another
accidental.

Anacrusis (Pickup Measure)

Incomplete first measure of a piece or a section of a piece of music.
See →Create new score, Time Signature...

Appoggiatura

A long grace note. See →grace note

Bar Lines

Vertical line through a staff or the system that separates measures .

http://musescore.org/en/forum/8
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Beam

Notes with a duration of an eighth or smaller either carry a flag or a
beam. Beams are used for grouping notes.

BPM

See →metronome mark

Breve

A double whole note or breve is a note that has the duration of two
whole notes.

Chord

The minimal definition of a chord is a minimum of two different notes
played together. Chords are based on the choices made by a composer
between harmonics of one, two or three (and more) fundamental sounds.
Ex. In the chord of C, G is the second harmonic, E the fourth of the
fundamental C. Now in C7, the B flat is the 6th harmonic of C and in C
Maj7 B is the second harmonic of E and the fourth harmonic of G...

Clef

Sign at the beginning of the Staff, used to tell which are the musical
notes on the lines and between the lines.
There are 2 F Clefs, 4 C Clefs and 2 G Clefs: F third, F fourth, C first, C
second, C third, C fourth, G first, G second (known as treble key too).
G first and F fourth are equivalent.
Clefs are very useful for transposition.

Crotchet

A crotchet is the British English term for what is called a quarter note
in American English. It's a quarter of the duration of a whole note
(semibreve).

Demisemiquaver

Thirty-second note

Duplet (engl.)

See →tuplet

Eighth note

A note whose duration is an eighth of a whole note (semibreve). Same as
British quaver.

Flag
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See →beam.

Flat

Sign that indicates that the pitch of a note has to be lowered one
semitone.

Grace note

Grace notes appear as small notes in front of a normal-sized main note. A
short grace note (acciaccatura) has a stroke through the stem; a long
grace note (appoggiatura) does not.

Half Note

A note whose duration is half of a whole note (semibreve). Same as
British minim.

Hemidemisemiquaver

Sixty-fourth note

Key Signature

Set of sharps or flats at the beginning of the staves. It gives an idea
about the tonality and avoids repeating those signs all along the staff.
A key signature with B flat means F major or D minor tonality.

Koron

An Iranian accidental which means lower in pitch and it lowers a note by
a quarter tone (In comparison to the flat which lowers a note by a
semitone). It is possible to use this accidental in a key signature.
See also →sori.

Longa

A longa is a quadruple whole note.

Metronome mark

Metronome marks are usually given by a note length equaling a certain
playback speed in bpm. Beats per minute (BPM) is the unit for measuring
tempo. In MuseScore, metronome marks are used in tempo texts.

Minim

A minim is the British term for a half note. It has half the duration of a
whole note (semibreve).

Natural
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A natural is a sign that cancels a previous alteration on notes of the same
pitch.

Part

Music to be played or sang by one or a group of musicians. In a string
quartet, 1st part = Violin 1, 2nd part = Violin 2, 3rd part = Alto, 4th part
= Cello.

Quaver

The British quaver is what is called in American eighth note. It has an
eighth the duration of a whole note.

Quadruplet

See →tuplet

Quintuplet

See →tuplet

Rests

Interval of silence of a specified duration.

Semibreve

A semibreve is the British term for a whole note. It lasts a whole
measure in 4/4 time.

Semiquaver

Sixteenth note

Semihemidemisemiquaver (Quasihemidemisemiquaver)

Hundred twenty-eighth note.

Sextuplet

See →tuplet

Sharp

Sign that indicates that the pitch of a note has to be raised one semitone.

Slur

Tie and Slur are two words used to describe a curved line between two 
or more notes. Slur means that the notes will be played without attack ( 
legato ). Tie is used between two or three ( rare ) of the same notes to
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indicate its duration: 
Quarter note + Tie + Quarter note = Half note, 
Quarter note + Tie + Eighth note = Dotted Quarter note 
Quarter note + Tie + Eighth note + Tie + 16th note = Double Dotted
Quarter note

Sori

An Iranian accidental which means higher in pitch and it raises a note by
a quarter tone (In comparison to the sharp which raises a note by a
semitone). It is possible to use this accidental in a key signature.
See →koron.

Staff (Staves)

Group of one to five horizontal lines used to lay on musical signs. In
ancient music notation (before 11th century) the staff may have any
number of lines.

System

System: Set of staves to be read simultaneously in a score.
Operating System (OS): Set of programs written in the aim to set up a
computer from a lot of electronic components. Popular OS are Microsoft
Windows, Mac OS X, and GNU/Linux.

Tie

See →slur.

Triplet (engl.)

See →tuplet.

Transposition

The tonality is quite meaningless: a tune can be played in any tonality.
The slight difference will be a darker or a more brilliant sound. But there
are many technical reasons to change the tonality of a score:

• The tune is too low or too high for a singer.

• The score is written for a C instrument and has to be played by a B
Flat one.

• The score is written for an orchestra and you want to imagine what
the horn, the flute and the clarinet are playing.

- In the first case all the orchestra will have to transpose: it's quite a 
impossible to do it without professional musicians but Musescore can 
do it very easily for you. 
- In the second case the musician must play D when a C is written. If



68

the score is written with a G 2nd Clef, he'll have to think that the staff
begins with a C 3rd Clef. 
- In the third case the conductor has to transpose all the staves which
are not written for C instruments... 
- In all cases the key signature must be mentally changed... 
Now, you must know that on some instruments (Horns and Tubas for
instance) the musicians transpose using alternative fingerings.

Tuplet

A tuplet divides it's next higher note value by a number of notes other
than given by the time signature. For example a triplet divides the next
higher note value into three parts, rather than two. Tuplets may be:
triplets, duplets, quintuplet, and other.

Velocity

The velocity property of a note controls how loudly the note is played.
This usage of the term comes from MIDI syntheiszers. On a keyboard
instrument, it is the speed with which a key is pressed that controls its
volume. The usual scale for velocity is 0 (silent) to 127 (maximum).

Voice

Polyphonic instruments like Keyboards, Violins, or Drums need to write
notes of different duration at the same time on the same Staff. To write
such things each horizontal succession of notes has to be written on the
staff independently.

Volta

In a repeated section of music, it is common for the last few measures of
the section to differ. Markings called voltas are used to indicate how the
section is to be ended each time. These markings are often referred to
simply as endings.

Keyboard shortcuts
Keyboard shortcuts can be customized via Edit → Preferences... → Shortcuts tab
(Mac: MuseScore → Preferences... → Shortcuts tab). Below is a list of of the initial
shortcut settings.

Navigation
Beginning of score: Home

Last page of score: End
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Next page: Pg Dn

Previous page: Pg Up

Next measure: Ctrl+Right (Mac: ⌘+Right)
Previous measure: Ctrl+Left (Mac: ⌘+Left)

Next note: Right

Previous note: Left

Note below (within a chord or on lower staff): Alt+Down

Note above (within a chord or on higher staff): Alt+Up

Top note in chord: Ctrl+Alt+Up (Ubuntu uses this shortcut for Workspaces
instead)
Bottom note in chord: Ctrl+Alt+Down (Ubuntu uses this shortcut for
Workspaces instead)

Note entry
Begin note entry mode: N
Leave note entry mode: N or Esc

Duration
For a list of shortcuts for each duration (such as quarter note, eighth note,
etc.) see note entry.

Half duration of previous note: Q
Double duration of previous note: W

Voices
Voice 1: Ctrl+I Ctrl+1 (Mac: TBC)
Voice 2: Ctrl+I Ctrl+2 (Mac: TBC)
Voice 3: Ctrl+I Ctrl+3 (Mac: TBC)
Voice 4: Ctrl+I Ctrl+4 (Mac: TBC)

Pitch
Pitches can be entered by letter name or MIDI keyboard. See note entry for
full details.

Repeat previous note: R

Raise pitch by octave: Ctrl+Up (Mac: ⌘+Up)
Lower pitch by octave: Ctrl+Down (Mac: ⌘+Down)

Raise pitch by semi-tone: Up

Lower pitch by semi-tone: Down

Add sharp to note: (undefined due to conflicts with zooming)
Add flat to note: -

Rest: 0 (zero). In versions 0.9.6 and earlier, Rest: Space
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Interval
Add interval above current note: Alt+[Number]
Add interval below current note: Shift+[Number]

Direction
Flip direction (stem, slur, tie, tuplet bracket, etc): X
Mirror note head: Shift+X

Articulations
Tie: +
Slur: S
Staccato: Shift+.

Crescendo: H
Decrescendo: Shift+H

Lyric entry
Previous lyric syllable: Ctrl+Left

Next lyric syllable: Ctrl+Right

Up to previous stanza: Ctrl+Up (Mac: ⌘+Up)
Down to next stanza: Ctrl+Down (Mac: ⌘+Down)

For more lyric shortcuts see lyrics

Display
Navigator: F12 (Mac: ⌥+⌘+N)
Play Panel: F11 (Mac: ⌥+⌘+P)
Palette: F9 (Mac: ⌥+⌘+K)
Mixer: F10 (Mac: M)
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Chapter 10

Create New Score

From the main menu choose File → New.... This opens the new score wizard.

Title, composer and other information

Enter the title, composer, or any other information as shown above. Notice
the two options at the bottom:

• Create new score from template

• Create new score from scratch

The first option offers a list of ready-made scores in the next screen. The
second option gives you the full choice of instruments in the next screen.
Templates are discussed in more detail below, but for now choose "Create
new score from scratch."

Click "Next" to continue.

Instruments and voice parts
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The instrument window is divided into two columns. The first column lists
instruments or voice parts to choose from. The second column is initially
empty but will soon contain a list of the instruments for your new score.

The instrument list in the first column is categorized into instrument
families. Double click a category to show the full list of instruments in each
family. Select an instrument and click "Add". The instrument you selected
now appears in the second column. You can add more instruments or voice
parts if needed.

The order of the instruments in the second column determines the order they
appear in the score. To change the order click on an instrument name and
use the "Up" or "Down" buttons to move it higher or lower. When you are
done click "Next".

Key signature
If you are using the latest version of MuseScore the wizard asks for a key
signature. Select the key signature you need and click "Next" to continue.

Time signature, pickup, and number of measures
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Set the time signature to the numbers you want. If your piece begins with a
pickup then mark the "Pickup measure" checkbox and adjust pickup time
signature to indicate the actual duration of the first measure.

If you know approximately how many measures you need you can specify
that here. Otherwise you can add or delete measures later.

Click "Finish" to create your new score.

Adjustments to score after creation
You can change any settings specified during the new score wizard even
after you start working on the score.

• To add or delete measures or create a pickup see Measure operations

• To change any text see Text editing. To add a missing Title (or other text
item) use the menu Create → Text → Title (or other text item)

• To add, delete, or change the order of instruments use the menu Create →
Instruments....

See also: Key signature, time signature, clef.

Templates
The first screen of the new score wizard has an option to "Create new score
from template" (see Title and other text above for details). To create a score
using this method select the template option and click "Next" to continue.

The next screen shows a list of templates. Select a template and click "Next".
Continue and finish the new score wizard as usual.

The template files are normal MuseScore files stored in the template folder. 
You can create your own templates by saving MuseScore files to the 
template folder. On Windows the template folder is usually located at 
C:\Program Files\MuseScore\templates. On Linux look under
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/usr/share/mscore-xxx if you installed from the package manager. If you
compiled mscore on Linux then look under /usr/local/share/mscore-xxx. On
Mac look under /Applications/MuseScore.app/Contents/Resources/templates

Licensed under the Creative Commons Attribution 3.0 license, 2002-2011
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