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Using Help

 

Using online Help

 

The Adobe

 

®

 

 Acrobat

 

®

 

 Reader application includes complete documentation in a PDF-
based help system. The help system includes information on all the Acrobat Reader tools, 
commands, and features for Microsoft

 

® 

 

Windows

 

®

 

, Mac

 

®

 

 OS

 

®

 

, UNIX

 

®

 

, and Linux

 

®

 

 systems. 
The file can also be printed out to provide a handy desktop reference.

 

To start online Help:

 

Do one of the following:

 

•

 

Choose Help > Reader Help.

 

•

 

Press F1 on your keyboard.

Reader Help will open in a new document window with the bookmark pane open. If the 
bookmark pane is not open, choose Window > Bookmarks, or press F5 on your keyboard. 
You can navigate the Help document using bookmarks, by using the Contents and Index 
navigation links, or by searching the document for the term you are looking for.

 

Using Bookmarks

 

The contents of Reader Help are shown as bookmarks in the Bookmark pane. Each 
bookmark is a hyperlink to the associated section of the Help document.

 

To find a topic using the bookmarks:

1

 

To view the contents, click the Bookmark tab. 

 

2

 

Click on a topic to view the first page of that topic.

As you view the contents in the document pane, the bookmark associated with that 
content is highlighted in the bookmark pane to help you easily identify where you are in 
the document. You can turn highlighting on or off by selecting Highlight Current 
Bookmark in the Bookmark pane menu (Windows).

 

3

 

To view subtopics, click the plus sign or arrow (Mac OS) next to a topic . The topic 
expands to show the subtopics it contains. Click the subtopic you want

 

Using the Contents page

 

The Contents page lists the main topics of the Reader Help document, and is the next 
main section after “Using Help.” To use the Contents page, go to that page and click the 
topic you want.
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Using the Find command

 

You can also search for any topic with the Find command.

 

To find a topic using the find command:

1

 

Choose Edit > Find.

 

2

 

Enter a word or a phrase in the text box, and click OK.

Reader searches the document, starting from the current page, and displays the first 
occurrence of the word or phrase you are searching for.

 

3

 

To find the next occurrence, choose Edit > Find Again.

 

Using the navigation bar

 

A navigation bar is provided at the top and bottom of each page of the Reader Help 
document. The Next Page  and the Previous Page  navigation arrows before and after 
the page number let you navigate through the pages one at a time. Clicking Back takes 
you to last page you viewed. You can also page through the document using the First 
Page, Previous Page, Next Page, and Last Page navigation arrows in the Reader toolbar.

 

Printing the Help file

 

Although Reader Help has been optimized for on-screen viewing, you can print out the file 
or portions of the file. To print, choose Print from the File menu, or click the printer icon in 
the Reader toolbar.

 

Other help resources

 

In addition to Reader Help, the Help menu provides you with other help resources, such as 
information about your version of Reader and information about plug-ins. See the Help 
menu for more information.
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Getting Started

 

The Acrobat® Reader allows anyone to view, navigate, and print documents in the Adobe 
Portable Document Format (PDF). It also allows anyone to perform full-text searches of 
PDF document collections that have been indexed using Acrobat Catalog (included with 
Adobe Acrobat® 5.0). 

 

Note:

 

 The Search feature is available only if your Reader installation includes the Search 
plug in, which is available on Windows

 

®

 

, Mac OS

 

®

 

, and some UNIX

 

®

 

 and Linux

 

®

 

 platforms.

 

You may make and distribute unlimited copies of Acrobat Reader, including copies for 
commercial distribution, as long as each copy you make and distribute includes all of the 
following:

 

•

 

The Acrobat Reader installer, exactly as provided by Adobe

 

•

 

The Acrobat Reader Electronic End User License Agreement

 

•

 

Copyright and other proprietary notices included in Acrobat Reader 

 

•

 

The following attribution statement on any media and packaging that includes Reader:

“Acrobat® Reader Copyright © 2002 Adobe Systems Incorporated. All rights reserved. 
Adobe, the Adobe logo, Acrobat, and the Acrobat logo are trademarks of Adobe Systems 
Incorporated.” 

The Acrobat Reader Electronic End User License Agreement and proprietary notices are 
contained in the Reader or Reader installer program. You are expressly prohibited from 
modifying or creating your own installer for the Acrobat Reader software. Details on the 
terms of use for the Acrobat Reader products are found in the Acrobat Reader Electronic 
End User License Agreement presented during installation of each product.

A special “Includes Adobe Acrobat” logo is available from Adobe for use when distributing 
Acrobat Reader. See the Adobe Web site http://www.adobe.com for details.

 

How to print this online guide

 

Although Acrobat Reader Help has been optimized for on-screen viewing, you can print 
out the file or portions of the file. 

 

To print:

 

Choose Print from the File menu, or click the printer icon in the Acrobat Reader toolbar.
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Using Acrobat Reader

 

The Adobe Acrobat Reader allows anyone to view, navigate, and print documents in the 
Adobe Portable Document Format (PDF). You may also fill out forms created with Adobe 
Acrobat in your Web browser, view documents with digital signatures, and view PDF 
documents on the Web in a variety of browser viewing scenarios. 

 

Opening PDF documents

 

The creator of a PDF document can set the document to open in a variety of ways. For 
example, a document might open to a particular page number, at a particular magnifi-
cation, or with the bookmarks or thumbnails visible.

If a document is set to open in Full Screen view, the tool bar, menu bar, and window 
controls are not visible. You can exit Full Screen view by pressing Escape, if your prefer-
ences are set this way, or by pressing Ctrl+L (Microsoft® Windows®, UNIX®, and Linux®) or 
Command+L (Mac OS). For more on this view, see “Reading documents in Full Screen 
view” on page 17.

 

To open a PDF document:

 

Do one of the following:

 

•

 

Click the Open button , or choose File > Open. In the Open dialog box, select the 
filename, and click Open. PDF documents usually have the extension .pdf. 

 

•

 

Choose the document’s filename from the File menu. The menu lists the last 10 PDF 
documents you opened.

 

•

 

Double-click the file icon in your file system.

 

Note:

 

 In Mac OS, you may not be able to open a PDF document created in Windows by 
double-clicking the icon. If double-clicking the icon in Mac OS does not open the 
document, use File > Open in Acrobat Reader to open the document, close the document, 
and try again. After you’ve used the Open command once on the document, you’ll be able 
to open the document next time by double-clicking.

 

In Acrobat Reader 5.0, you can view and print PDF documents that contain Japanese, 
Korean, Traditional Chinese, and Simplified Chinese text if you use the appropriate 
language kit at installation.

To display a list of all Acrobat Reader command-line options (UNIX and Linux), start the 
Acrobat Reader product with the -help option. For example:

 

acroread -help
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Viewing PDF documents on the Web

 

You can view PDF documents that are on the World Wide Web or an intranet using a Web 
browser. Every document on the Web is identified by a unique address called a Uniform 
Resource Locator (URL). When a PDF document is stored on the Web, you can click a URL 
link to it to open the document in your Web browser. 

 

Reading PDF documents in a Web browser 

 

In Windows and Mac OS, PDF documents can display in Web browsers compatible with 
Netscape Navigator 4.0 (or later) or Microsoft Internet Explorer 4.0 (or later). The necessary 
plug-ins are automatically installed when you install Acrobat Reader. For information on 
getting your browser ready, see “Installing the Web browser plug-in” on page 30. (If pages 
of your PDF document appear blank when viewed in a Web browser, you may be using an 
early version of a Web browser. Try saving the PDF file locally, and viewing it using Acrobat 
Reader.)

When you view a PDF document in a Web browser, all of the Acrobat Reader tools are 
available in the browser. In Windows, you can click the two small vertical lines (next to the 
Adobe icon at the left of the tool bar) to minimize or maximize the tool bar.

 

Note:

 

 Many keyboard commands are mapped to the Web browser rather than to Acrobat 
Reader, so some Acrobat Reader keyboard shortcuts may not be available in the browser 
window.

 

In UNIX and Linux, PDF documents can display in Web browsers compatible with Netscape 
Navigator 4.x only or as a helper application in Netscape 6. To set up Netscape compati-
bility, launch Netscape using the script called “netscape,” which is located in the Browsers 
subdirectory where Acrobat 5.0.5 was installed. (You may need to edit this script for your 
particular configuration. See the README file for more details.) If you have problems with 
integrating Acrobat with Netscape or plan to use Forms, follow the instructions in the 
README file to link your Netscape browser to the Acrobat 5.0.5 Reader application.

 

Note:

 

 Forms submit is only available through the browser. In this instance, you need to use 
Netscape Navigator 4.x.

 

Buying PDF documents from the Web (Windows and 
Mac OS)

 

The Web Buy feature lets you buy and download eBooks, reference works, technical 
manuals, structured business documents, newspapers, and periodicals

 

 

 

as PDF files that 
have been locked with the Adobe secure PDF technology to protect the copyrights of 
authors and publishers. Web Buy lets you unlock these files so that you can read and 
search them on your personal computer or reading device. A series of Web pages pops up 
in your browser to guide you through the process. 

Sellers of electronic documents may require that the use of an electronic document be 
tied to a particular computer or storage device. You can specify in the Web Buy prefer-
ences dialog box what computer or storage device information you are willing to make 
available to sellers automatically when you purchase a secure PDF document over the 
Web. An advisory page will pop up in your Web browser if a seller seeks information other 
than that you have defined in your Web Buy preferences dialog box.
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To set your Web Buy preferences:

1

 

Select Edit > Preferences > Web Buy. 

 

2

 

Define the information you want to make available automatically to a seller:

 

•

 

Select Internal computer ID to give the seller your computer ID. You cannot edit your 
computer ID from this dialog box.

 

•

 

Select User Identifier (Logon Name) to give the seller your user ID. You cannot edit your 
user identifier from this dialog box.

 

•

 

Select Storage Device for Document if you want to lock the PDF document to the 
default storage device in your computer.

 

Note:

 

 If you lock a document to a portable device such as a Zip cartridge or Jaz drive, the 
document is portable. If you lock a document to your computer, the document can be read 
only on that machine.

 

•

 

Select the Other Identifier (Windows) or Alternate Identifier (Mac OS) text box to lock 
the document to a storage device such as a Zip cartridge or a Jaz drive that is visible to 
your computer. To add a storage device to the Other Identifier (Windows) or Alternate 
Identifier (Mac OS) text box, be sure the storage device is installed, and then click 
Refresh (Windows) or Refresh Device List (Mac OS) in the dialog box. All the devices 
that are visible to your computer are listed in the right panel. Select the required 
storage device, and click the arrow to copy the storage device to the text box. Select 
the required text box.

 

3

 

Click OK.

 

Important:

 

 You must set the Certified plug-ins only option in the General preferences to 
use the Web Buy feature. The Certified Plug-ins Only option loads only Adobe-certified 
third-party plug-ins. This option must be selected if you are using the Web Buy feature. If 
you change this option, you must restart Acrobat by clicking Relaunch in the General 
Preferences dialog box. 
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Reading downloaded PDF files

 

The Rotate View buttons on the command bar let you rotate pages clockwise or counter-
clockwise for easier viewing. The Retain View On Close option in the Preferences file makes 
Acrobat Reader open electronic documents at the last page you were looking at when you 
closed the document, and at the same view.

 

To rotate the displayed page:

 

Do one of the following:

 

•

 

Click the Rotate View 90

 

o 

 

CW button 

 

 

 

or Rotate View 90

 

o 

 

CCW button 

 

 

 

on the 
command bar to rotate the displayed page clockwise or counterclockwise, respectively. 
The page is rotated in 90-degree increments.

 

•

 

Choose View >Rotate Clockwise or View Rotate Counterclockwise.

 

To set the Retain View On Close option:

 

Choose Edit > Preferences > Retain View On Close. (Your document will open automati-
cally at the same page and view when the option is selected.)

 

Opening a PDF file embedded as an OLE object in 
another file (Windows)

 

You can read PDF documents that have been incorporated into other documents created 
by any OLE (Object Linking and Embedding) 1.0 or OLE 2.0 container application such as 
Microsoft Word, Excel, or PowerPoint.

 

To view an embedded PDF file:

1

 

Open the document into which the PDF document has been embedded.

 

2

 

Double-click the Acrobat icon in the document. Acrobat Reader launches and displays 
the activated PDF document.

 

Note: 

 

You cannot make changes or save while in Acrobat Reader.

 

Printing PDF documents 

 

You can print and view PDF documents from Acrobat Reader.

 

To print a PDF document:

1

 

Use File > Page Setup to set general printing options. The available options will vary 
with different printers and drivers. See your printer driver documentation for details.

 

2

 

Click the Print button , or choose File > Print. Specify the printer, page range, 
number of copies, and other options, and click OK. Most of the options are the same as 
they are for other applications, but note the following:

 

•

 

Selected Pages Or Selected Graphic (Windows) or Selected Thumbnails/Graphic (Mac 
OS) prints only the pages or page area you selected before opening the Print dialog 
box.

 

•

 

Page From/To prints a range of pages. In Windows, UNIX, and Linux, if the Use Logical 
Page Numbers option is selected in General preferences, you can enter page-position 
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numbers in parentheses to print those pages. For example, if the first page of a 
document is numbered “iii”, you can enter (1) to print that page.

 

•

 

Odd prints only odd-numbered pages.

 

•

 

Even prints only even-numbered pages.

 

•

 

Selected Pages or Selected Graphic (Windows) or Selected Thumbnails/Graphic (Mac 
OS, UNIX, and Linux) prints only the pages or page area you selected before opening 
the Print dialog box.

 

•

 

Reverse order prints the pages in reverse order. Depending on your printer, this can 
enable pages to be printed so that the top page is the first page in the document.

 

•

 

Comments prints comment graphics on the pages. The comments are printed as 
closed, even if they are open on the pages online.

 

•

 

Shrink Oversized Pages to Paper Size scales pages down (and if necessary rotates them) 
to fit the paper size currently installed in your printer. This option is not available in 
most other applications.

 

•

 

Expand Small Pages to Paper Size scales pages up (and if necessary rotates them) to fit 
the paper size currently installed in your printer. This option is not available in most 
other applications.

 

•

 

Optimize for Speed downloads fonts to the printer as they are needed. With this option 
checked, the pages must be printed in the order in which Acrobat Reader emits them.

 

•

 

Download Asian Fonts downloads Asian fonts to a PostScript printer. Select this option 
if you want to print a PDF document with Asian fonts but do not have the fonts 
installed on the printer and do not have the fonts embedded in the document. 
(Embedded fonts are downloaded whether or not this option is selected.) You can use 
this option with a PostScript Level 2 or higher printer, or a Level 1 printer that supports 
Type 0 font extensions.

 

Note:

 

 Some fonts cannot be downloaded to a printer, either because the font is a bitmap 
or because embedding of the font is restricted in that document. In these cases, a 
substitute font is used for printing, and the printed output may not match the screen 
display exactly. 

 

If Download Asian Fonts is not selected, the PDF document prints correctly only if the 
referenced fonts are installed on the printer. If the fonts are not on the printer but the 
printer has similar fonts, the printer substitutes the similar fonts. If there are no suitable 
fonts on the printer, Courier is used for the text.

If you have a PostScript Level 1 printer that does not support Type 0 font extensions, or if 
Download Asian Fonts does not produce the results you want, print the PDF document as 
a bitmap image. Printing a document as an image may take longer than using a substi-
tuted printer font.

 

•

 

Print Method (Language Level 1, 2, 3), in Windows, UNIX, and Linux, specifies which 
level of PostScript to generate for the pages. Choose the level of PostScript appropriate 
for your printer. In Mac OS, this specifies whether to print using PostScript (without 
selecting level) or to print pages as bitmap images.

 

•

 

Save Printer Memory downloads all the fonts for a given page to the printer before the 
page is printed. When unchecked, print jobs may be smaller but require more printer 
memory.
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Printing PDF documents from the command line (UNIX 
and Linux)

 

Besides printing directly from within Reader by choosing File > Print, you can print PDF 
files from the command line. The syntax for printing from the command line is: 

 

acroread -toPostScript <options> <pdf filename>

 

Note:

 

 If a PDF file has been secured with an Open password or does not allow printing, you 
will not be able to print from the command line.

 

For example, to print the file

 

 sample.pdf

 

 to the default printer, type the following:

 

% cat sample.pdf | acroread -toPostScript | lp

 

You can use 

 

<options>

 

 to control your print job from the command line. Options 
available to Reader are the following.

 

To create a Language Level 1, 2, or 3 file:

 

-level1 or -level2 or -level3

 

Note

 

: -level2 is the default setting.

 

To print a PDF file to a differently named PostScript file:

 

-pairs <pdf filename1> <PostScript filename1> <pdf filename2> 
<PostScript filename2> ...

 

For example, to print 

 

sample.pdf 

 

to 

 

test.ps

 

, you would use the following syntax:

 

acroread -toPostScript -pairs sample.pdf test.ps

 

To use the printer’s default halftone screens instead of custom halftone screens 
included in the file:

 

-printerhalftones

 

To create a binary PostScript file:

 

-binary

 

To download fonts once per document rather than once per page:

 

-fast

To download fonts to the printer as they are needed:

-optimizeForSpeed

To download all the fonts for a given page to the printer before the page is printed:

-saveVM (corresponds to the Save Printer Memory checkbox on the print dialog)

To print a range of pages:

-start <page number> -end <page number>

To print the document in a landscape orientation:

-landscape

To reverse the page order of the output:

-reverse
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To output only odd-numbered pages:

-odd

To output only even-numbered pages:

-even

To shrink, expand or rotate a document, as necessary, to fit the page on which it will 
be printed:

-shrink

To scale the document:

-scale <scale factor>

To control the page size:

-size <page size>

where width and height can be numbers or letter, tabloid, ledger, legal, 
executive, a3, a4, a5, b4, b5, or wxh (custom paper size where w is the 
integer width in points and h is the integer height in points).

To turn off the print comments feature:

-commentsOff

To set the tranparency quality:

-transQuality <quality factor> 

where quality factor is an integer from 1 to 5. With a setting of 1, everything is rasterized, 
and with a setting of 5, everything is vectorized. This value is used as a suggestion to the 
flattening port when transparency is flattened during printing.

To reproduce whites correctly if the PostScript interpreter is not doing so:

-brokenCRD 

Use this command only if white objects are printing out incorrectly (as peach, for 
instance).

Printing and viewing PDF documents containing 
Asian fonts
If you are working on UNIX or Linux, or on an operating system that does not have support 
for Asian languages, in order to enable the viewing and printing of PDF files that contain 
Asian language text, you will need to separately download and install one or more of the 
Asian language font packs that are available on the Adobe Web site (www.adobe.com). 
Fonts are available for Chinese Traditional, Chinese Simplified, Japanese, and Korean 
languages.
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Setting preferences
Preferences are settings that modify the performance, interface, and behavior of an appli-
cation. For the most part, the preference settings of Acrobat Reader determine the view of 
a document on-screen for your copy of Reader. Some of these settings can be overridden 
for a particular PDF document by a document author.

In UNIX and Linux, you can define resources in the .Xdefaults file. See “Customizing 
resources for your personal use (UNIX and Linux)” on page 12 for information. You can also 
give Acrobat Reader access to more fonts system-wide or for individual users. See “Giving 
Acrobat Reader access to fonts (UNIX and Linux)” on page 13 for information.

To set preferences:

Choose Edit > Preferences, and then choose the type of preference you want to change:

• General preferences define a default page layout, a default magnification level, a color 
management system, and other basic options. For more information, see “Setting a 
default view” on page 15. 

• Comments preferences specify a font and point size for viewing note text. For more 
information, see “Setting comments preferences” on page 25.

• Full Screen preferences determine how a document appears and behaves in Full Screen 
view. For more information, see “Setting Full Screen preferences” on page 18.

• Search lets you change the default settings in the Search Preferences dialog box to add 
more choices to your Search dialog box. “Setting search preferences” on page 38.

• Web Buy preferences let you specify what computer or storage device information you 
are willing to make available to sellers automatically when you purchase a secure PDF 
document over the Web. For more information, see “Buying PDF documents from the 
Web (Windows and Mac OS)” on page 6.

• Weblink preferences determine the behavior of information display for Weblinks and 
provide a way to choose which browser to launch when activating a Weblink. For more 
information, see “Choosing a Web browser for Weblinks” on page 19.

Other Acrobat Reader plug-ins may add new preference items to this list. See the plug-in’s 
documentation for information.

Customizing resources for your personal use (UNIX and 
Linux)
When Acrobat Reader starts, it searches for resources in the standard X Window System 
resource file (~/.Xdefaults). It uses all resources it finds to determine the proper setup. If it 
finds a resource more than once, it uses the last value found. By editing the resource file, 
you can customize Acrobat Reader. For your changes to take effect, you must restart your 
windowing system.

The following sections describe some general Acrobat Reader resources that you can 
change in the .Xdefaults file:

• “Plug-in location (UNIX and Linux)” on page 13.

• “Starting multiple Acrobat viewers (UNIX and Linux)” on page 13.

• “Fonts for bookmarks (UNIX and Linux)” on page 13.
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Plug-in location (UNIX and Linux)
When Acrobat Reader starts, it searches for plug-ins in the directory $ACRO_INSTALL_DIR/
$ACRO_CONFIG/plug_ins. You can specify a new default directory by changing the 
*systemPlugInPath label. The *systemPlugInPath label specifies the location of the plug-
ins used by all users of Acrobat Reader:

*systemPlugInPath /net/Acrobat/Sun_OS4/doc_dept/plug-ins

You can specify your own plug-ins when starting Reader. By default, Acrobat Reader 
searches for personal plug-ins in the $HOME/plug_ins directory. You can specify a new 
default directory for personal plug-ins by changing the *userPlugInPath label. For 
example:

*userPlugInPath $HOME/Acrobat/plug_ins

Starting multiple Acrobat viewers (UNIX and Linux)
If you want to open a new Reader program and run multiple viewers, you must specify 
-useFrontEndProgram from the command line. By default, the most recently opened 
viewer is the one in use. For example:

% acroread -useFrontEndProgram

Fonts for bookmarks (UNIX and Linux)
If you want to change the default font size used for bookmarks, you can change the value 
of *bookmarkFontSize. The font size is expressed in points. If you want to change the font 
family, you can change the value of *bookmarkFontName. For example:

*bookmarkFontSize 10

*bookmarkFontName Courier

Giving Acrobat Reader access to fonts (UNIX and Linux)
If a font is referenced in a PDF file, but not embedded, and Acrobat Reader finds that font 
on the system opening the file, Acrobat Reader will use the font on the system to display 
the text. You can give Reader access to your installed Type 1 (base 12) fonts by setting the 
PSRESOURCEPATH variable in the viewer launch script or in your user configuration file. 
Editing the launch script, usually done by a system administrator, gives all users who 
access that copy of the viewer access to the fonts. Editing your user configuration file gives 
you access to the fonts.

The PSRESOURCEPATH variable looks for UNIX and Linux PostScript Resource (.upr) files in 
the location at which you point it. The .upr files are created when Type1 fonts are installed. 
If you have installed Adobe Illustrator® or Adobe Photoshop®, the PSRESOURCEPATH is 
already set for the individual and Reader will find it.

To give access to fonts system-wide:

1 Open Acrobat4/bin/acroread in a text editor.

2 Enter the following command:

# PSRESOURCEPATH=<font_location>::
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3 Restart Acrobat Reader.

To give an individual access to fonts:

1 Open your user configuration file in a text editor.

2 Set the PSRESOURCEPATH environment variable:

# PSRESOURCEPATH=<font_location>::

3 Restart Acrobat Reader.

Magnifying and reducing the page view
The minimum and maximum zoom levels available depend on the current page size.

If you magnify a page to a size larger than the window, use the hand tool  to move the 
page around so that you can view all the areas on it. Moving a PDF page with the hand 
tool is like moving a piece of paper on a desk with your hand.

To increase magnification:

Do one of the following:

• Select the zoom-in tool , and click the page.

• Select the zoom-in tool, and drag to draw a rectangle, called a marquee, around the 
area to magnify.

• Click the Magnification button  in the status bar, and choose a magnification level.

• Choose View  > Zoom In.

• Choose View  > Zoom To, specify a magnification level, and click OK.

To decrease magnification:

Do one of the following:

• Select the zoom-out tool , and click the page.

• Select the zoom-out tool, and drag to draw a marquee the size you want the reduced 
page to be.

• Click the Magnification button  in the status bar, and choose a magnification level.

• Choose View  > Zoom Out.

• Choose View  > Zoom To, specify a magnification level, and click OK.

Note: When the zoom-in tool is selected, you can press Ctrl (Windows, UNIX, and Linux) or 
Option (Mac OS) while clicking or dragging to zoom out instead of in. When the zoom-out 
tool is selected, press Ctrl or Option to zoom in.

To change the magnification level using a thumbnail:

Position the pointer over the lower right corner of the red page-view box in the thumbnail 
until the pointer changes to a double arrow . Then drag the corner of the box to reduce 
or expand the view of the page.

To resize a page to fit the window:

Do one of the following:
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• To resize the page to fit entirely in the window, click the Fit in Window button , or 
choose View > Fit in Window.

• To resize the page to fit the width of the window, click the Fit Width button , or 
choose View > Fit Width. Part of the page may be out of view.

• To resize the page so that its text and graphics fit the width of the window, choose 
View > Fit Visible. Part of the page may be out of view.

To return a page to its actual size:

Click the Actual Size button , or choose View > Actual Size. The actual size for a PDF 
page is typically 100%, but the document creator may have set it to another magnification 
level.

Setting the page layout
You can use three page layouts when viewing PDF documents: 

• Single Page layout displays one page in the document pane at a time.

• Continuous layout arranges the pages in a continuous vertical column.

• Continuous - Facing layout arranges the pages side by side. This configuration accom-
modates a two-page spread display and multiple-page viewing in the window. If a 
document has more than two pages, the first page is displayed on the right to ensure 
proper display of two-page spreads.

Single Page layout, Continuous layout, Continuous - Facing layout

In Single Page layout, the Edit > Select All command selects all text on the current page. In 
Continuous and Continuous - Facing layouts, it selects all text in the PDF document.

To set page layout: 

Do one of the following:

• Click the Page Layout button  in the status bar, and choose a page layout

• Choose Single Page, Continuous, or Continuous - Facing from the View menu.

To see two-page spreads most efficiently, use the Continuous - Facing page layout, and 
choose View > Fit Width.

Setting a default view
You can set a default viewing magnification, a default page layout, and other viewing 
defaults in the General Preferences dialog box. These settings apply to any document that 
has been set to open in the default view.

In UNIX and Linux, the first time you open Acrobat Reader, a preferences file named prefs 
is created in your $HOME directory. 
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To set a default view:

Choose Edit > Preferences > General. Define a default page layout, a default magnification 
level, a color management system, and other basic options, and click OK:

• Default Page Layout sets a page layout used for scrolling when you first open a 
document. You can display pages one at a time as you scroll, continuously one above 
the next, or continuously side by side.

• Page Units specifies a unit of measure for displaying page size in the status bar and in 
the Crop dialog box.

• Substitution Fonts specifies multiple master fonts that Acrobat Reader uses to 
substitute for Type 1 and TrueType fonts not available on your computer. If PDF 
documents do not print because of insufficient printer memory, choose Sans from the 
Substitution Fonts pop-up menu. If you change this setting, the change takes effect the 
next time you start Windows or Mac OS.

• Application Language (Win and Mac OS) sets a language for the Acrobat Reader user 
interface. The pop-up menu shows the languages you installed with Acrobat Reader. If 
you choose a different language, the change takes effect the next time you start the 
application.

• Use Greek Text Below displays text below the designated point size as gray lines (or 
greeked text) to speed display time.

• Display Large Images displays images larger than 128K. If you do not select this option, 
a gray box appears in place of a large image. Selecting this option can slow down 
paging through a document.

• Display Transparency Grid displays a grid behind transparent objects.

• Display Page To Edge prints PDF documents to the edge of the pages. If you do not 
select this option, pages from PDF documents are printed with a white border, as 
defined by the printer driver.

• Use Logical Page Numbers allows you to set page numbering in a PDF document using 
the Document > Number Pages command. You typically do this when you want PDF 
page numbering to match the numbering printed on the pages. A page’s number, 
followed by the page position in parentheses, appears in the status bar and in the Go To 
Page, Delete Pages, and Print dialog boxes. For example, if the first page in a document 
is numbered “i”, it might appear as “i(1 of 10)”. If this option is not selected, Acrobat 
ignores page numbering information in documents and numbers pages using arabic 
numbers starting at 1.

• Smooth Text smooths the edges of text to minimize the contrast between the 
background and the text. This sometimes improves the quality of the display on-screen, 
especially with larger text sizes.

• Smooth Images smooths the edges of monochrome images to minimize the contrast 
between the background and the image.

• Smooth Line Art smooths the edges of line art to minimize the contrast between the 
background and the text or image. This sometimes improves the quality of the display 
on-screen, especially at larger magnifications.

• Use Cool Type lets you adjust the Acrobat text display to work optimally with your LCD 
monitor, such as used with laptop computers. When you choose this option, you must 
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also calibrate CoolType by clicking Configure CoolType and choosing the text sample 
that looks the best.

• Default Zoom sets the magnification level for PDF documents when they are first 
opened. This affects only documents that have Default set for their magnification in 
Document Info > Open.

• Max “Fit Visible” sets the maximum magnification level for the Fit Visible view and for 
viewing articles.

• Color chooses a color management system for interpreting color accurately across 
devices. 

• Allow Background Downloading allows a PDF document to continue downloading 
from the Web, even after the first requested page displays on-screen in a Netscape 
Navigator-compatible browser. If you do not select this option, only the requested 
page downloads to your computer, and other pages are downloaded as you request 
them.

Note: You will get unexpected results from the Go Back command in your Web browser if 
you do not select this option. For example, if you link to another document from a partially 
downloaded PDF document and then want to return to that document by using Go Back, 
you return to the first page of the PDF document, even if you were not on the first page. 
This option should alleviate most cases of unexpected Go Back behavior in your Web 
browser.

• Display Splash Screen At Startup shows the splash screen each time Acrobat Reader is 
started.

• Open Cross-Doc Links In Same Window opens linked PDF documents and views in one 
window to minimize the number of windows open in Acrobat Reader. If you do not 
select this option, a new window is opened for each new Go To View link. If a linked 
document is open when a Go To View link to it from another document is activated, the 
document remains open in a separate window.

Note: To override this setting, either selected or deselected, you can press Ctrl (Windows, 
UNIX. and Linux) or Option (Mac OS) when clicking a link.

• Use Page Cache places the next page in a buffer even before you view the page in 
Acrobat Reader. This reduces the amount of time it takes to page through a document.

• Allow File Open Links warns you of security risks when you open a file in another appli-
cation from a link in a PDF document and gives you a chance to cancel the operation. If 
this option is not selected, links to files in other applications are disabled.

Reading documents in Full Screen view
In Full Screen view, PDF pages fill the entire screen; the menu bar, command bar, tool bar, 
status bar, and window controls are hidden. A document creator can set a PDF document 
to open in Full Screen view, or you can set the view for yourself. Full Screen view is often 
used for presentations, sometimes with automatic page advancement and transitions.

The pointer remains active in Full Screen view so that you can click links and open notes. 
You can use keyboard shortcuts for navigational and magnification commands, even 
though the menus and tool bar are not visible. You can also set preferences to define how 
Full Screen view appears on your system.
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To read a document in Full Screen view:

Choose View > Full Screen. Press Return or the Down or Right Arrow key to page through 
the document. Press Shift-Return or the Up or Left Arrow key to page backwards through 
the document.

Note: If you’re using Mac OS and have two monitors installed, the Full Screen view of a 
page appears on only one screen. To page through the document, click the screen 
displaying the page in Full Screen mode.

To exit Full Screen view:

Press the Escape key, if your Full Screen preferences are defined this way, or press Ctrl+L 
(Windows, UNIX, and Linux) or Command+L (Mac OS).

Setting Full Screen preferences
Choose Edit > Preferences > Full Screen to set the characteristics of the Full Screen view. 
These settings apply to any document you open in Full Screen view and that does not 
have its own Full Screen settings.

The default settings are usually acceptable and do not need to be changed.

To set preferences for Full Screen view:

1 Choose Edit > Preferences > Full Screen.

2 Select the navigation options:

• Advance Every specifies whether to advance automatically from page to page every set 
number of seconds. You can page through a document using mouse or keyboard 
commands even if automatic paging is selected.

• Advance On Any Click lets you page through a PDF document by clicking the mouse. If 
this is not selected, you can page through a document by pressing Return, Shift-Return 
(to go backwards), or the arrow keys.

• Loop After Last Page lets you page through a PDF document continuously, returning to 
the first page after the last. This option is typically used for setting up kiosk displays.

• Escape Key Exits lets you exit Full Screen view by pressing the Escape key. If this is not 
selected, you can exit by pressing Ctrl+L (Windows, UNIX, and Linux) or Command+L 
(Mac OS).

3 Choose the appearance options:

• Background Color specifies the window’s background color. If you choose Custom, the 
system color palette is displayed. See your computer’s user guide for instructions on 
setting a custom color.

• Default Transition specifies the transition effect to display when you switch pages in Full 
Screen view.

• Mouse Cursor specifies whether to show or hide the cursor in Full Screen view. 

• Zoom To (Mac OS) selects a monitor to use for Full Screen view when two monitors are 
installed. You can choose Main (for the monitor with the menu bar), Largest Inter-
section (for the monitor that displays the largest portion of the document), Deepest (for 
the monitor with the most colors), Widest (for the monitor with the greatest horizontal 
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resolution), Tallest (for the monitor with the greatest vertical resolution), or Largest Area 
(for the monitor with the most pixels).

4 Click OK.

Choosing a Web browser for Weblinks
When you click a Weblink in a PDF document, the default browser opens for you to view 
the linked document. Before this happens, however, you have to identify the default 
browser to Acrobat Reader. You can also choose to show or hide the Web browser button 
and link information and status.

1 Choose Edit > Preferences > Weblink.

2 From the menu, choose whether to display link information below the pointer when 
the pointer is over a Weblink. You can display a URL for a Weblink always, never, or only 
when you press Ctrl (Windows, UNIX, and Linux) or Option (Mac OS) while pointing on the 
link. 

3 Set the following options for displaying Web information:

• Show Toolbar Button shows the Web Browser button  in the command bar. You can 
click this button to open the Web browser from Acrobat Reader.

4 Click Browse (Windows, UNIX, and Linux) or Select (Mac OS), locate the Web browser 
you want to use, and click Open.

5 Choose the connection type that matches your browser. If your browser is not listed, 
choose the Standard connection type.

6 Click OK.

Displaying information about a document
The Document Info submenu of the File menu contains commands that display infor-
mation about a document. 

To display document information:

Choose File > Document Properties, and then choose a type of document info:

• Summary to display basic creation information about the PDF document. For more 
information, see “Getting General information about a document” on page 20.

• Fonts displays font usage information. For more information, see “Getting information 
about fonts used in a document” on page 20.

• Index gives the name of an autoindex associated with the file. Opening the file adds the 
associated index to the list of indexes that can be searched.The Choose button in this 
dialog box allows you to mount a different index for the file.

• Embedded Data Objects lists any embedded data objects in the PDF file (these are files 
of other types that are contained in the PDF).To add an embedded data object, click 
Import.To launch the embedded file, select a listed embedded data object, and click 
Open.To save a listed embedded data object to a new location, select it, and click 
Export.To remove a listed embedded data object from the PDF, select it, and click 
Delete.



Back 20  

Adobe Acrobat Help Using Acrobat Reader 

Back 20  

To display the document’s security settings:

Choose File > Document Security. For more information, see “Getting information about 
security settings” on page 20.

Getting General information about a document
The General Info dialog box provides title, subject, author, and keyword information if it 
has been provided. It also displays attributes set by Acrobat, PDFWriter, or Distiller® in this 
dialog box:

• Creator indicates the program that created the original document (if known).

• Producer indicates the application or driver that produced the PDF document.

• Created indicates the date and time the document was created.

• Modified indicates the date and time the document was last modified.

• Optimized indicates whether the file has been optimized. (Optimized files can be 
downloaded one page at a time from a Web server.)

• File Size indicates the size of the PDF file.

Note: The title is the document’s title, not necessarily the filename (unless the title and 
filename are identical). The title and filename appear in the title bar in the document 
window.

Getting information about fonts used in a document
The Font Information dialog box lists the original font used in the original document, font 
type, font encoding, and the font used in Reader to display the original font. Only the fonts 
encountered in the document so far are listed. To see a list of all fonts used in the entire 
document, click the List All Fonts button.

You can use the Font Information dialog box to see what fonts were used in the original 
document and whether the same fonts are being used as you view it. If substitute fonts 
are being used and you aren’t satisfied with their appearance, you may want to install the 
original fonts on your system or ask the document creator to recreate the document with 
the original fonts embedded in it.

While Acrobat Reader creates a substitute font in Mac OS, the pointer appears as a 
spinning letter a.

Getting information about security settings
The Security Information dialog box lists the security settings that have been assigned to 
the selected PDF file. 

A PDF document author can choose to restrict access to a file by requiring an open 
password or by restricting the use of certain tools and commands. If a file requires an open 
password, you must enter the password to view the file. When a file has restricted access, 
any restricted tools and menu items are dimmed.
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Paging through a document
Acrobat Reader provides buttons, keyboard shortcuts, and menu commands for paging 
through PDF documents. 

To go to another page:

Do one of the following:

• To go to the next page, click the Next Page button  in the command bar or status bar, 
press the Right Arrow key, press Ctrl (Windows, UNIX, and Linux) or Option (Mac OS) 
and the Down Arrow key, or choose Document > Next Page.

• To go to the previous page, click the Previous Page button  in the command bar or 
status bar, press the Left Arrow key, press Ctrl (Windows, UNIX, and Linux) or Option 
(Mac OS) and the Up Arrow key, or choose Document > Previous Page.

• To move down one line, press the Down Arrow key.

• To move up one line, press the Up Arrow key.

Note: The Down and Up Arrow keys move you one line at a time when you are not in Fit in 
Window view. In Single Page mode, these keys move you one page at a time if the page fills 
the entire screen.

• To move down one screenful, press Page Down or Return.

• To move up one screenful, press Page Up or Shift+Return.

• To go to the first page, click the First Page button  in the command bar or status bar, 
press the Home key, or choose Document > First Page.

• To go to the last page, click the Last Page button  in the command bar or the status 
bar, press the End key, or choose Document > Last Page.

To jump to a page by its number:

Do one of the following:

• Select the current page number in the status bar, type the page number to jump to, and 
press Return.

If the Use Logical Page Numbers option is selected in General preferences, and if your 
document’s page numbers are different from the page position in the PDF file, the page 
position appears in parentheses in the status bar. For example, if a first page is numbered 
“iii”, the numbering might appear as “iii(1 of 10)”. You can double-click inside the paren-
theses, edit the page-position number, and press Return to go to that page.

• Choose Document > Go To Page, type the page number, and click OK.

If the Use Logical Page Numbers option is selected in General preferences, and your 
document’s page numbers are different from the page position in the PDF file, you can 
enter the page-position number in parentheses in Go To Page to go to that page.

• Drag the vertical scroll bar until the number of the page you want to jump to is 
displayed.

To retrace your viewing path:

Do one or more of the following:

• To retrace your path within a PDF document, click the Go to Previous View button  in 
the command bar, or choose Document > Go Back (Windows Mac OS) or 
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Document > Go to Previous View (UNIX and Linux) for each step back. Or click the Go to 
Next View button , or choose Document > Go Forward (Windows Mac OS) or 
Document > Go to Next View (UNIX and Linux) for each step forward.

• To retrace your viewing path through other PDF documents, choose Document > Go 
Back Doc (Windows Mac OS) or Document > Go to Previous Document (UNIX and 
Linux) for each step back or Document > Go Forward Doc (Windows Mac OS) or 
Document > Go to Previous Document (UNIX and Linux) for each step forward. Or hold 
down Shift, and click the Go Back or Go Forward button. This command opens the 
other PDF documents if the documents are closed.

Browsing with thumbnails
A thumbnail is a miniature view of each document page, which you can display in the 
overview area. You can use a thumbnail to jump quickly to a page and to adjust the view 
of the current page.

To browse with a thumbnail:

1 Show the Thumbnails palette. You may need to choose Window > Show Thumbnails to 
open the palette or click the Thumbnails tab to bring the palette to the front of its group.

2 Do one of the following:

• To jump to another page, double-click the page’s thumbnail.

• To display another part of the current page, position the pointer over the edge of the 
page-view box in the page’s thumbnail until the pointer changes to a hand tool . 
Then drag the box to move the view area.

Note: If thumbnails appear as gray boxes in the overview area, the document author did 
not create them for you. You can still use the thumbnails without the miniature views or 
you can ask the document author to create them for you.

Browsing with bookmarks
Bookmarks can mark parts of a document for quick access, link to page views in other 
documents, link to the Web, play a movie or sound, enter an article, or reset or submit a 
form. 

To browse with a bookmark:

1 Show the Bookmarks palette. You may need to choose Window > Show Bookmarks to 
open the palette or click the Bookmarks tab to bring the palette to the front of its group.

2 To jump to a topic using its bookmark, click the bookmark’s icon or text in the palette. 

Note: Clicking a bookmark might perform an action, such as playing a movie, instead of 
taking you to another location. It depends on how the bookmark was defined.

The bookmark for the part of the document currently showing is boldfaced.

If the navigation pane disappears when you click a bookmark, the document creator has 
activated the Hide After Use command. To show the navigation pane again, click the Show 
Navigation Pane button on the command bar. Deselect Hide After Use in the navigation 
pane’s palette menu if you want the navigation pane to remain open after you click a 
bookmark. 
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Bookmarks can be subordinate to other bookmarks in their hierarchy; a higher-level 
bookmark in this relationship is the parent, and a lower-level bookmark is the child. You 
can collapse a parent bookmark in the palette to hide all its children. When a parent 
bookmark is collapsed, it has a plus sign (Windows) or a triangle (Mac OS) next to it. If the 
bookmark you want to click is hidden in a collapsed parent, click the plus sign or triangle 
next to the parent to show it.

Following links
Links can connect parts of a document, jump to other PDF documents, open another 
application file, go to a location on the Web, play a movie or sound, enter an article, hide or 
show a comment, import form data, or reset or submit a form. 

To follow a link:

1 Select the hand tool , a zoom tool, or a selection tool. 

2 Position the pointer over the linked area on the page until the pointer changes to a 
hand with a pointing finger . (The hand has a plus sign in it if the link points to the 
Web.) Then click the link.

Note: Clicking a link might perform an action, such as playing a movie, instead of taking 
you to another location. It depends on how the link was defined.

You can press Shift while pointing on a linked area to use the tool instead of activating the 
link. For example, you might press Shift and point on a link with the text selection tool to 
select and edit the link’s text.

Note: A Web browser must be chosen in your Weblink preferences to follow a Weblink. See 
“Choosing a Web browser for Weblinks” on page 19 for more information.

Reading articles
Articles connect related parts of a document by creating a reading path through the 
document. Articles are usually created to make reading documents with multi-column 
magazine articles easier.

To read an article:

1 Do one of the following:

• Show the Articles palette. Then double-click the article’s icon in the palette to start 
reading at the beginning of the article.

• Select the hand tool . Then click in the article to start reading it at that point, or press 
Ctrl (Windows, UNIX. and Linux) or Option (Mac OS) and click anywhere in the article to 
start reading at the beginning.

2 The pointer changes to the follow article pointer . Navigate through the article:

• To go to the next page in the article, press Return or click.

• To go to the previous page, press Shift-Return, or press Shift and click.

• To go to the beginning of the article, press Ctrl (Windows, UNIX, and Linux) or Option 
(Mac OS) and click.
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• To exit the article before reaching the end, press Shift-Ctrl (Windows, UNIX, and Linux) 
or Shift-Option (Mac OS) and click.

3 When you reach the end of the article, the pointer changes to the end article pointer 
. Press Return or click to return to the view displayed before you starting reading the 

article.

Finding words
You can use the Find command to find a complete word or part of a word in the current 
PDF document. Acrobat Reader looks for the word by reading every word on every page in 
the file, including text in form fields.

To find a word using the Find command:

1 Click the Find button , or choose Edit > Find.

2 Enter the text to find in the text box.

3 Select search options if necessary:

• Match Whole Word Only finds only occurrences of the complete word you enter in the 
text box. For example, if you search for the word stick, the words tick and sticky will not 
be highlighted.

• Match Case finds only words that contain exactly the same capitalization you enter in 
the text box.

• Find Backwards starts the search from the current page and goes backwards through 
the document.

• Ignore Asian Character Width finds only those Kana characters that exactly match the 
text you enter.

4 Click Find. Acrobat Reader finds the next occurrence of the word.

To find the next occurrence of the word:

Do one of the following:

• Choose Edit > Find Again.

• Reopen the Find dialog box, and click Find Again. (The word must already be in the Find 
text box.)

Reviewing comments
The comments feature of Adobe Acrobat 5.0 lets a user attach annotations to an existing 
document. These comments can be in the form of notes, text, audio, stamps, files, graphic 
markups, and text markups. In Reader, you can open comments and review their contents; 
you cannot edit the comments, nor can you launch file attachments or play sound 
comments. Notes do not print directly from the document that they annotate.

To review notes:

Do one of the following:

• To open a note, double-click the note icon.
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• To close a note, click the close box in the upper left corner of the note window. (If the 
note is selected, Mac OS users can also press Command+W.)

Setting comments preferences
You can set the font and point size for comments.

To set preferences for comments:

1 Choose Edit > Preferences > Comments.

2 Select a font style from the Font menu.

3 Enter a number for the Font Size or choose a size from the pop-up menu.

4 Click OK.

Playing movies or sounds
Windows and Mac OS viewers can play movies and sounds added to a PDF document. To 
play movies or sounds in Windows, your computer must have the appropriate sound and 
video boards installed, and Apple QuickTime 2.0 or later or the Microsoft Video for 
Windows software. In Mac OS, you need QuickTime 2.0 or later. 

To play a movie clip:

1 Select the hand tool .

2 Move the cursor over a movie. The cursor changes to a filmstrip.

3 Click to begin playing the clip.

4 Click again to stop playing, or press Escape.

Note: Movies and sounds can also play in a document if specified as an action by a link, 
bookmark, form field, or page action.

Viewing documents with digital signatures
Acrobat Reader 5.0 allows you to view and print PDF documents with digital signatures; it 
does not allow you to validate digital signatures or digitally sign PDF documents. A digital 
signature may appear in a document as text, a graphic, or a handwritten facsimile. 

Acrobat 5.0 (Windows and Mac OS) offers full support for digital signatures.

Filling out forms
You can fill out forms in PDF documents in Acrobat Reader and submit them across the 
Web if you are viewing PDF documents in your Web browser window. Otherwise, print the 
form with the data from Reader.

To fill out a form:

1 Select the hand tool .

2 Position the pointer inside a form field, and click. The I-beam pointer allows you to type 
text. The arrow pointer allows you to select a button, a check box, a radio button, or an 
item from a list.
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3 After entering text or selecting an item, check box, or radio button, do one of the 
following:

• Press Tab to accept the form field change and go to the next form field.

• Press Shift+Tab to accept the form field change and go to the previous form field.

• Press Enter (Windows) or Return (Mac OS) to accept the form field change and deselect 
the current form field.

In a multiline text form field, Enter or Return goes to the next line in the same form field. 
You can use Enter on the keypad to accept a change and deselect the current form field.

• Press Escape to reject the form field change and deselect the current form field. 

Pressing Escape when you are in Full Screen mode causes you to exit Full Screen mode. 
Pressing Escape a second time rejects the form field change and deselects the current 
form field.

4 Once you have filled in the appropriate form fields, click the Submit Form button, if one 
exists. The button may be named differently. Clicking this button sends the form data to a 
database across the Web or over your company intranet. This button only works if you are 
viewing the PDF document from inside a Web browser.

Important: Saving to disk, either by exporting form data or saving the filled-in form, is 
available only in Acrobat. 

To clear a form in a browser window:

Do one of the following:

• Select a Reset Form button, if one exists.

• Exit the Acrobat viewer without saving the file, and start again.

Clicking the Reload button or the Go Back button, or following a link in a World Wide Web 
browser window, does not clear a form.

Important: There is no undo for this action. 

Copying and pasting text and graphics to another 
application
You can select text or a graphic in a PDF document, copy it to the Clipboard, and paste it 
into a document in another application such as a word processor. You can also paste text 
into a PDF document note or into a bookmark.

Once the selected text or graphic is on the Clipboard, you can switch to another appli-
cation and paste it into another document.

Note: If a font copied from a PDF document is not available on the system displaying the 
copied text, the font cannot be preserved. A default font is substituted.

To select text and copy it to the clipboard:

1 Select the text select tool , and do one of the following:

• To select a line of text, select the first letter of the sentence or phrase and drag to the 
last letter.

• To select multiple columns of text (horizontally), hold down Ctrl (Windows, UNIX, and 
Linux) or Option (Mac OS) as you drag across the width of the document. 



Back 27  

Adobe Acrobat Help Using Acrobat Reader 

Back 27  

• To select a column of text (vertically), hold down Ctrl+Alt (Windows) or 
Option+Command (Mac OS) as you drag the length of the document.

• To select all the text on the page, choose Edit > Select All. In Single Page mode, all the 
text on the current page is selected. In Continuous or Continuous - Facing mode, most 
of the text in the document is selected. When you release the mouse button, the 
selected text is highlighted. To deselect the text and start over, click anywhere outside 
the selected text.

The Select All command will not select all the text in the document. A workaround for this 
(Windows) is to use the Edit > Copy command.

2 Choose Edit > Copy to copy the selected text to the Clipboard. 

3 To view the text, choose Window > Show Clipboard.

In Windows 95, the Clipboard Viewer is not installed by default, and you cannot use the 
Show Clipboard command until it is installed. To install the Clipboard Viewer, choose 
Start > Settings > Control Panel > Add/Remove Programs, and then click the Windows 
Setup tab. Double-click Accessories, check Clipboard Viewer, and click OK.

To copy graphics to the Clipboard:

1 Select the graphics select tool  by holding down the mouse button on the text select 
tool and dragging to the graphics select tool. Or press Shift-V as necessary to cycle 
through the group of tools. The cursor changes to the cross-hair icon.

2 Drag a rectangle around the graphic you want to copy. To deselect the graphic and start 
over, click anywhere outside the selected graphic.

3 Choose Edit > Copy to copy the graphic to the Clipboard. 

4 To view the graphic, choose Window > Show Clipboard. The graphic is copied using the 
WMF (Windows), PICT (Mac OS), or XPIXMAP (UNIX and Linux) format. In UNIX and Linux, 
the graphic is pasted in the primary selection. 

Using PDF on the Web
PDF documents can be published on the World Wide Web and read in Web browsers or in 
Acrobat viewers used as helper applications with Web browsers. For more information, see 
“Web viewing scenarios” on page 27, “Page-at-a-time downloading” on page 28, and 
“Reading PDF on the Web” on page 28.

Web viewing scenarios
Here are four possible scenarios for viewing PDF on the Web:

• The browser supports PDF viewing, the PDF file is optimized, and the Web server 
supports page-at-a-time downloading (byte-serving), so the PDF file downloads a page 
at a time and displays in the Web browser window. This is the fastest scenario possible 
for viewing PDF documents on the Web.

• The browser supports PDF viewing, but the PDF file is not optimized or the server does 
not support byte-serving, so the entire PDF file downloads to the machine with the 
browser and then appears within the browser window.
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• The browser supports PDF viewing, and PDF files are embedded in an HTML page. An 
ActiveX browser such as Internet Explorer supports navigating through the document. 
Netscape Navigator-compatible browsers can display the PDF document within an 
HTML page, but require a link to a full-window view for navigation. 

• Acrobat or Acrobat Reader is configured as a helper application for the browser, and the 
browser may support PDF viewing within the browser window. The entire PDF file 
downloads to the machine with the browser, and the Acrobat viewer launches as a 
separate application and displays the PDF document.

See also “Setting up Acrobat Reader as a helper application” on page 29.

Page-at-a-time downloading
With page-at-a-time downloading (byte-serving), the Web server sends only the 
requested page of information to the user, not the entire PDF document. As a reader of 
the PDF document, you do not have to do anything to make this happen; it is communi-
cated in the background between Acrobat Reader and the Web server. If you want the 
entire PDF document to continue downloading in the background while you view the first 
page of requested information, be sure Allow Background Downloading is selected in the 
General preferences dialog box (default).

If your Web server does not support page-at-a-time downloading, you can use a CGI appli-
cation to do it.

Reading PDF on the Web
Each document or other resource on the Web is identified by a unique uniform resource 
locator (URL) address. Clicking a URL link to a PDF document on the Web can open the 
document identified by the URL in your Web browser for inline viewing, or in Acrobat 
Reader if Reader has been set up as a helper application for your browser. You can also 
read PDF files that have been embedded in HTML documents on the Web. For more infor-
mation, see “Reading PDF in a Web browser” on page 28, “Reading embedded PDF files” 
on page 29, and “Setting up Acrobat Reader as a helper application” on page 29.

Reading PDF in a Web browser
PDF documents can display in Web browsers compatible with Netscape Navigator 3.0 (or 
later) or Internet Explorer 3.0 (or later). The necessary plug-ins are automatically installed 
when you install Acrobat Reader. For information on getting your browser ready, see 
“Setting up Acrobat Reader as a helper application” on page 29. (For additional installation 
information, see “Installing the Web browser plug-in” on page 30.)

When you view a PDF document in a Web browser, all of the Acrobat Reader tools are 
available in the browser. In Windows, you can click the two small vertical lines (next to the 
Adobe icon at the left of the toolbar) to minimize or maximize the toolbar.

Note: Many keyboard commands are mapped to the Web browser rather than to Acrobat 
Reader, so some Acrobat Reader keyboard shortcuts may not be available in the browser 
window.
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Visiting the Adobe Web site
Click the Adobe Web Site button to link directly to the Adobe Web site (www.adobe.com). 
This page contains valuable information about new technology, links to Acrobat plug-ins, 
and more. On the Adobe Web site home page, you can click a country name in the Adobe 
Sites pop-up menu to choose a language for viewing the site. The exact information in the 
site may vary from one language version to another.

Searching on the Web
Some Web search engines index PDF documents as well as HTML documents on Web 
servers. And some search engines support PDF search highlighting, although not all 
search engines that support PDF indexing support search highlighting.

If you visit a Web site that uses a search engine that indexes PDF documents, your search 
results list may include PDF documents. If the Web site uses a search engine that supports 
PDF search highlighting, and if you open one of the PDF documents in the search results 
list, the Highlight Next  and Highlight Previous  buttons activate on the Acrobat 
Reader tool bar in your Web browser. The search term is also highlighted in the document.

To go to the next search hit, click the Highlight Next button. To go to the previous hit, click 
the Highlight Previous button. These two commands jump across PDF documents, but not 
across HTML documents.

Reading embedded PDF files
HTML pages can include embedded PDF documents. An embedded PDF document 
normally displays an image of the first page of the document in the HTML document. The 
PDF document can be configured by the HTML author to display, when clicked, in a 
separate window. The document displays in a browser window or in an Acrobat Reader 
window, depending on how you have configured your browser.

If an embedded PDF file is not configured to open in a separate window, you can interact 
with the file in a browser compatible with Internet Explorer, but not one compatible with 
Netscape Navigator. For example, links would not be active in a PDF file displayed 
embedded in HTML in Netscape Navigator, but they would be active in Internet Explorer. 

Setting up Acrobat Reader as a helper application
If your Web browser does not display PDF documents in the browser window, or if you 
prefer not to view PDF documents in the Web browser, you can set up Acrobat Reader as a 
helper application in your browser’s preferences. Then, when you view a PDF document 
on the Web, Acrobat Reader will start and display the document. When Acrobat Reader 
works as a helper application, you cannot use page-at-a-time downloading, form 
submittal in a browser, or search highlighting on the Web, and you cannot view 
embedded PDF documents.

To set up your Web browser to recognize PDF files, you must define a MIME type and a file 
type. The file type should be pdf. The MIME type should be application/pdf. See your 
browser’s documentation for information on configuring it.
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If you are using Netscape Navigator 2.0 or later with Windows or Mac OS, and if you want 
to use Acrobat Reader as a helper application, rename the PDFViewer plug-in or delete it 
from the Netscape plug-in folder. The plug-in is named nppdf32.dll (Windows) or 
PDFViewer (Mac OS).

To use Acrobat Reader as a helper application in Windows:

1 Choose Edit > Preferences > General.

2 Select Web Browser Integration and click OK. 

Note: This is not necessary in Mac OS.

Installing the Web browser plug-in
Browsers compatible with Netscape Navigator need the nppdf32.dll file (Windows), the 
nppdf.so file (UNIX and Linux), or PDFViewer plug-in (Mac OS) to display PDF. When you 
install Acrobat Reader with Search, this plug-in is automatically installed in the Netscape 
plug-in folder (Win and Mac OS), if you have Navigator on your system. If you install 
Navigator after installing Acrobat Reader, or if you’re using another browser compatible 
with Navigator, you can install this plug-in yourself. To set up Netscape Navigator on a 
UNIX and Linux system, you must run the Netscape launch script located in the Browser 
folder (see “Reading PDF documents in a Web browser” on page 6).

To install the Web browser plug-in (Windows):

1 Open the Browser folder in the Acrobat Reader folder.

2 Copy the nppdf32.dll file to your Web browser’s plug-ins folder.

To install the Web browser plug-in (Mac OS):

1 Open the Web Browser Plug-in folder in the Acrobat Reader folder.

2 Copy the PDFViewer plug-in to your Web browser’s plug-ins folder.

To install the Web browser plug-in (UNIX and Linux):

Run <installdir>/Browsers/netscape.
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Searching Catalog Indexes
The Acrobat Search command allows you to perform full-text searches of PDF document 
collections that have been indexed using Acrobat Catalog, whereas the Acrobat Find 
command allows you to search only a single document. The Find command is further 
limited by having to look at every word on every page. For these reasons, searches of full-
text indexes created using Catalog are faster and more convenient than using the Find 
command. The Search command also provides powerful tools for limiting and expanding 
a search.

Note: The Search feature is available only if your Reader installation includes the Search 
plug in, which is available in Windows, Mac OS, and some UNIX and Linux platforms.

About searching Acrobat Catalog indexes
The focus of your search will depend a lot on how the index was constructed. Consider the 
following questions before setting search options and defining search queries:

• Was document and date information provided for the PDF documents, and can it be 
used for searching? 

• Were common words and numbers excluded when the index was built? 

A well-built index will often include a file that provides information that can help you plan 
your search strategies. 

Searching indexes
To search an index created using Adobe Catalog, you first select the indexes to search, 
define a search query, select the documents to review from those returned by the search, 
and then view the occurrences of the search term within the documents you selected to 
review. A search query is an expression made up of text and other items to define the infor-
mation you want to find. 

Opening a PDF document associated with an index automatically makes the index 
searchable.

Selecting indexes
You can search any or all indexes displayed in the Index Selection dialog box. Dimmed 
indexes are not available for searching.

To customize index selection:

1 Choose Edit > Search > Select Indexes to list the currently available indexes and to add 
or delete indexes, and then do one of the following in the Index Selection dialog box:

• To add an index to the available indexes list, click Add, navigate to the index, and 
double-click on the index file.

• To remove an index, select the index name, click Remove, and then click OK.
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• To select or deselect an index, select the box for the index, and then click OK. Indexes 
that are grayed out are currently unavailable for searching.

• To view information about an available index, highlight the index name, click Info, and 
then click OK. The information displayed includes the build date, creation date, number 
of documents in the index, location of the index, and information provided by the 
builder of the index. 

Using the Search command
The Search command allows you to perform a search on PDF documents. You can search 
for a simple word or phrase, or you can expand your search query by using wild-card 
characters and operators. You can use the search options to further refine your search. And 
if document and date information were provided for the documents you are searching, 
you can use that information to narrow your search. 

To perform a full-text search:

1 Choose Edit > Search > Query. 

2 Type the text you want to search for in the Find Results Containing Text box:

The text that you type in can be a single word, a number, a term, or a phrase. It can be a 
word, with or without wild-card characters (*, ?), or any combination of letters, numbers, 
and symbols. Because you can use Boolean operators in the text box, you must enclose 
any search term that includes and, or, or not in quotes. You can also use the operators =, ~, 
and != with text, but only to perform exact matches, contains, and does not contain 
searches, respectively. You can use comparison operators (<, <=, >, >=) with values of the 
same type. For more information, see “Tips on defining search queries” on page 36. 

To clear the search dialog box and redefine the search, click Clear. 

3 To refine your search query, select one or more of the search options: Word Stemming, 
Sounds Like, Thesaurus, Match Case, or Proximity. If the search options are not displayed in 
the Acrobat Search dialog box, restore them by choosing File > Preferences > Search, and 
selecting Show Options. For information on how these options affect your search query, 
see “Setting the search options” on page 35.

Note: Before you perform a search with one of these options, you can preview the type of 
results you’ll receive using the Word Assistant. For more information, see “Using Word 
Assistant” on page 34.

4 To refine your search query using document and date information, enter document 
information values in the Title, Subject, Author, and Keywords text boxes, and enter date 
information in the creation and modification date text boxes. If these text boxes are not 
displayed in the Acrobat Search dialog box, restore them by choosing File > Preferences > 
Search, and selecting Show Fields and Show Date.

5 Select Search. The Search dialog box is hidden, and documents that match your search 
query are listed in the Search Results window in order of relevancy.

6 Double-click a document that seems likely to contain the relevant information, 
probably the first document in the list. The document opens on the first match for the text 
you typed.

7 Click the Search Next button or Search Previous button to go to other matches in the 
document. Or choose another document to view.
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Alternatively, you can redefine the query by typing new text in the Acrobat Search dialog 
box or by using other techniques to expand the search to include more documents or to 
limit the search to fewer documents. For more information, see “Limiting searches” on 
page 37.

Viewing documents returned from searches
A search returns a list of indexed documents containing items that match your search 
query. The results are displayed in the Search Results window. When you open a 
document in the list, you view only pages containing matches. All the matches on a page 
are highlighted.

Documents more likely to contain relevant information are listed first on the list. The 
relevancy ranking of each document is indicated by an icon. The degree of fill in the circle 
in the icon indicates the probability that the document contains the search information. A 
solid fill indicates a high probability that the document contains your search term; an 
empty circle indicates a low probability that the document contains your search term.

Relevancy ranking for search results

The relevancy ranking also depends on how you defined your search query:

• When you use ordinary search text, the relevancy ranking indicates how frequently the 
search word appears in the document. This means both in absolute terms and relative 
to the number of other words in the document.

• When you use a Boolean OR operator between two words or phrases in a search, 
documents that contain both items have a higher relevancy ranking than documents 
that contain just one item. 

• When you use the Proximity option, the closer the matches are within a document, the 
higher the relevancy ranking of that document.

To view a document returned from a search:

1 Double-click the document name to open the document. 

2 Use the Search buttons on the tool bar to view all the matches for your query.

3 Review the search results that automatically appear in the text box:

• To highlight the next occurrence of a match in the document, click Next Highlight

• To highlight the previous occurrence of a match in a document, click Previous 
Highlight .

• To highlight the first occurrence of a match in the next document listed or previous 
document listed, Shift-click Next Highlight or Previous Highlight. 

• To view any other document listed, select Search Results  to redisplay the list, and 
then double-click the document name.
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Refining your searches
If your search returns too many documents or provides too many matches in individual 
documents, you can pare down the search results by confining the search to documents 
returned by a previous search, or you can more narrowly define your search term, use the 
document and date information, and use the general search options and the Word 
Assistant. Alternatively, if your search did not provide the information you were looking 
for, you can broaden your search query using the search options, for example.

Note: If the search options and document and date information text boxes are not 
displayed in the Acrobat Search dialog box, restore them by choosing File > Preferences > 
Search, and selecting Show Options. 

Refining searches in progress
If you want to narrow a search further, you can refine or confine your search to documents 
listed in a prior search. For example, you can first search for (and find) all documents by an 
author, and then define a search query for that subset of documents. The result would be a 
subset of documents that are authored by the specified author and that contain the 
search string. 

To refine a search:

1 Choose Edit > Search > Results to display the Search Results window. Select and show 
the results of a previous search.

2 In the Search dialog box, refine or replace the query that produced the list of 
documents.

If you used a simple text string for the search query, you might consider refining the 
search query by using the search options, by including document and date information in 
the search, or by using Word Assistant. For more information, see “Using Word Assistant” 
on page 34.

3 Press Ctrl (Windows, UNIX, and Linux) or Option (Mac OS). The button label changes 
from Search to Refine. 

4 Click Refine. This produces a Search Results list of documents that are a subset of the 
previous list and that match the new query.

Using Word Assistant
Word Assistant enables you to build a list of terms that will appear when you specify a 
search using the Sounds Like, Word Stemming, or Thesaurus options. The resulting list 
shows you if the option you are using is likely to return helpful results. If the list is too long 
or full of irrelevant words, you can quickly construct a list of words to find by copying 
words from the Word Assistant dialog box and pasting them into the search dialog box.

To use the Word Assistant with search options:

1 Choose Edit > Search > Word Assistant.

2 To check the available indexes or change the selection of indexes, click Indexes.

3 In the Index Selection dialog, select the indexes you want to use, and click OK.

4 Select a search option (Sounds Like, Word Stemming, or Thesaurus) from the Assist 
menu.

5 Enter the search word in the Word text box, and click Look Up. 
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To copy words from the Word Assistant dialog box:

1 Choose Edit > Search > Query to open the Search dialog box.

2 Use the Word Assistant to generate a list of related words.

3 Double-click a word to search. 

4 Double-click and copy the word in the Word text box to the clipboard.

5 In the Search dialog box, select the Find text box, and paste in the selected word.

6 Repeat steps 3 through 5 for each word you want to use; separate each pair of words in 
the Find text box with AND or OR.

Setting the search options
You can expand your search term by using the search options Sounds Like, Word 
Stemming, or Thesaurus. To determine if your choices will be useful in limiting your search, 
you can use the Word Assistant to build a list of terms that will appear when you specify 
these options. For more information, see “Using Word Assistant” on page 34.

You can limit your search term by using the search options Match Case and Proximity.

To set the search options:

In the Search dialog box, select one or more of the options: 

• Word Stemming finds words that contain part of (a word stem) the specified search 
word. It applies to single words, not phrases; does not apply to words that contain wild-
card characters (*, ?); finds words that end in ing, ed, s, ion, and so on, but not er; and 
cannot be used with the Match Case option. Word Stemming works only for indexes 
built with this option.

• Sounds Like finds different spellings for proper names. It applies to single words, not 
phrases; does not apply to words that contain wild-card characters; and cannot be used 
with the Match Case option. Sounds Like works only for indexes built with this option.

• Thesaurus finds similar words that appear in the documents you are searching, not 
necessarily all the similar words you might find in a complete thesaurus. It applies to 
single words, not phrases; does not apply to words that contain wild-card characters; 
and cannot be used with the Match Case option.

• Match Case limits the results of the search by finding only those documents that 
contain words with the same capitalization. It can be used with a Boolean expression 
and with terms that use wild-card characters. Characters matched by wild-card 
characters can be either uppercase or lowercase. 

• Proximity limits the results of simple AND searches to one pair of matches per 
document—the pair closest together. The two matches must be within three pages or 
fewer of each other. This option is useful for locating a document that concentrates on 
some topic of interest. 

Proximity affects relevancy ranking in searches. The closer the matches are within a 
document, the higher the ranking. Proximity does work with complex AND searches—
such as, Hawaii AND (cruise OR fly). 

If you want to keep the search dialog box small, you can hide (or keep hidden) the 
options and type in their names in the Find Results Containing Text box. Along with the 
text box names, you need to use operators such as = (equals) and > (greater than). For the 
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options, type in /st (stemming), /so (sounds like), /th (thesaurus), /ca (match case), or /pr 
(proximity).

Searching with Document Info and Date Info
If document and date information was provided for the documents you are searching, you 
can use this information in the Search dialog box to limit your search. For example, you 
can limit your search to documents authored by one person and created or modified 
within a given period or on a given date. You can view the document and date information 
(if any) provided by choosing File > Document Info > General from within the PDF 
document.

If you want to keep the search dialog box small, you can hide the document and date text 
boxes and type the text box names in the Find Results Containing box. You will need to 
use operators such as = (equals) and > (greater than).

To search using Document Info:

In the Search dialog box, enter your search query information in the appropriate Title, 
Subject, Author, and Keywords text boxes. You can use Boolean operators and wild-card 
characters in these text boxes, with the search text. All documents that contain the value 
are returned. If the With Document Info text boxes are not displayed in your Search dialog 
box, choose File > Preferences > Search, and select Show Fields. You may see additional 
custom text boxes in your display, depending on the information supplied for the PDF 
document.

To search using Date Info: 

In the Search dialog box, do one of the following:

• Enter a date (month, day, year), or use the Up and Down Arrow keys to select a value.

• To limit a search to documents created or modified after a specific date, specify the after 
date, and leave the before date blank.

• To limit a search to documents that were created or modified before a specific date, 
specify the before date, and leave the after date blank.

• To create a Boolean AND condition, enter the creation and modification dates in the 
Search dialog box. An AND condition returns only documents created or modified 
during the specified period. 

If the With Date Info text boxes are not displayed in your Search dialog box, choose 
File > Preferences > Search, and select Show Date. 

Tips on defining search queries
You can improve your search by narrowly defining the term or phrase you search for, 
being aware that some words (stopwords) and numbers may have been excluded when 
the index was built, and by using wild-card characters and Boolean operators.

Searching for terms or phrases
• If your search phrase includes the words and, or, or not used in their ordinary sense (not 

as a Boolean operator), put the phrase in quotes. The search phrase

“once or twice”
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finds all occurrences of the phrase once or twice, not all occurrences of once and all occur-
rences of twice as it would without the quotes.

• If your search phrase includes punctuation (other than an apostrophe) or special 
characters (such as @ and *), they are ignored. For example, either of the terms

son-in-law, son in law

finds all occurrences of both son-in-law and son in law.

Excluding stopwords, numbers, and separator characters
• If you are unsuccessful in searching for a phrase that includes a common word, it is 

probably because it is a specified stopword. 

• If you are unsuccessful in searching for a term that includes numbers, it is probably 
because numbers have been excluded from the index. Acrobat Catalog defines a 
number to be a sequence of one or more digits (0 through 9), optionally preceded by a 
minus sign (-), optionally separated by one or more commas (,) or periods (.), and 
optionally containing a decimal point, which can be a period (.) or a comma (,).

• If you use a separator character in a search term, it is automatically discarded. Separator 
characters include all symbols, the space character, and punctuation characters except 
the apostrophe. When indexing a PDF document, Acrobat Catalog uses separator 
characters to recognize where one term ends and the next term begins.

• If alphanumeric terms are made up of numbers and separator characters, they can also 
be excluded.

Expanding searches
• Use wild-card characters in the search text to increase the number of matches for the 

text. 

• Use an asterisk (*) to match zero, one, or more characters; use a question mark (?) to 
match any one character.

• Use wild-card characters in a term that is part of a Boolean expression. 

• Use wild-card characters to specify Document Info text box values. However, you 
cannot use wild-cards to represent separator characters such as the hyphen (-) and the 
slash (/).

• Use Boolean expressions in Document Info text box values. 

• Use a Boolean OR operator between two words to return documents containing either 
word.

• Use the Sounds Like, Word Stemming, and Thesaurus options to increase the number of 
matches for the text.

• Use a comma (,) or vertical bar (|) to separate items in an OR search.

Limiting searches
• Use a Boolean NOT operator before a word or search term to exclude documents 

containing the word or search term. 

• Use an exclamation point (!) as another way to specify a NOT search. However, be sure 
to place a space between the exclamation point and the search item.
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• Use a Boolean AND operator between two words to return only documents containing 
both words.

• Use the Proximity option to limit AND searches. This specifies that words must be in 
close proximity to each other—within three pages or fewer.

• Use the Match Case option to match exact capitalization.

Using Boolean operators
To avoid building inaccurate search queries, follow these guidelines:

• When NOT is used with either or both of the AND and OR operators, it is evaluated 
before either the AND or OR. For example, evolution AND NOT Darwin finds all 
documents that contain the word evolution but not the word Darwin.

• When you combine AND and OR in the same expression, AND is evaluated before OR. 
For example, Darwin OR origin AND species finds all documents that contain Darwin or 
that contain both origin and species.

• When you use parentheses, you change the default order of evaluation for Boolean 
operators. For example, (Darwin OR origin) AND species finds all documents that contain 
either Darwin and species or that contain origin and species. Parentheses can be nested.

• When you use a literal phrase that contains an operator name, a symbol for an operator 
name (such as & for AND), or parentheses, the phrase must be enclosed in quotation 
marks. For example: “cats and dogs” finds all documents that contain the phrase cats 
and dogs, not all documents that contain either the word cats or the word dogs. The 
phrase cats & dogs also needs quotes to be interpreted literally.

In addition to and, or, not, and parentheses, the symbols that require quotation marks are 

However, quoted search phrases that contain parentheses or vertical bars can produce 
unexpected results.

Using operators
You can use operators in text and Document Info text boxes.

• You can use =, ~, and != with text only to perform exact matches, contains, and does not 
contain searches, respectively.

• You can use comparison operators (<, <=, >, >=) with values of the 
same type.

Setting search preferences
You can change the default settings in the Search Preferences dialog box to add more 
choices to your search dialog box, if necessary. For example, if you check Show Fields, a 
With a Document Info section is added to the search dialog box.

& AND

| and , OR

 ! NOT
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To change search preferences:

1 Choose File > Preferences > Search.

2 Set the preferences in the dialog box as necessary:

• Show Fields displays Document Info fields. For more information, see “Searching with 
Document Info and Date Info” on page 36.

• Show Options displays search word options. For more information, see “Setting the 
search options” on page 35.

• Show Date displays the date of the items returned by a search query.

• Hide on Search hides the dialog box during a search.

• Sort By allows you to specify a sort by Modified, Producer, Score, Subject, Title, Author, 
Created, Creator, or Keywords.

• Show Top displays a specified number of documents that are the first returned from the 
search.

• Hide on View hides the dialog box when viewing results.

• Highlight Display allows you to specify highlighting By Page, By Word, or No Highlight.

3 Click OK.
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Legal Notices

Copyright
© 2002 Adobe Systems Incorporated. All rights reserved.

Adobe® Acrobat® Reader 5.0 User Guide for Windows®, Macintosh®, UNIX®, and Linux®.

This manual, as well as the software described in it, is furnished under license and may be 
used or copied only in accordance with the terms of such license. The content of this 
manual is furnished for informational use only, is subject to change without notice, and 
should not be construed as a commitment by Adobe Systems Incorporated. Adobe 
Systems Incorporated assumes no responsibility or liability for any errors or inaccuracies 
that may appear in this documentation. Except as permitted by such license, no part of 
this publication may be reproduced, stored in a retrieval system, or transmitted, in any 
form or by any means, electronic, mechanical, recording, or otherwise, without the prior 
written permission of Adobe Systems Incorporated.

Please remember that existing artwork or images that you may want to include in your 
project may be protected under copyright law. The unauthorized incorporation of such 
material into your new work could be a violation of the rights of the copyright owner. 
Please be sure to obtain any permission required from the copyright owner.

Any references to company names in sample templates are for demonstration purposes 
only and are not intended to refer to any actual organization.

Adobe, the Adobe logo, Acrobat, Acrobat Catalog, Acrobat Distiller, Acrobat Exchange, 
Acrobat Reader, Acrobat Search, Adobe Type Manager, ATM, FrameMaker, Illustrator, 
ImageReady, PageMaker, Photoshop, and PostScript are either registered trademarks or 
trademarks of Adobe Systems Incorporated in the United States and/or other countries. 
ActiveX, Microsoft, Windows and Windows NT are either registered trademarks or trade-
marks of Microsoft Corporation in the United States and/or other countries. Apple, 
ColorSync, Mac, Macintosh, Power Macintosh, QuickTime, and TrueType are trademarks of 
Apple Computer, Inc. registered in the U.S. and other countries. QuickTime and the 
QuickTime logo are trademarks used under license. Pentium is a registered trademark of 
Intel Corporation. Java, Java Applet, and JavaScript and are trademarks or registered trade-
marks of Sun Microsystems, Inc. in the United States and other countries. UNIX is a regis-
tered trademark of The Open Group. Linux is a registered trademark of Linus Torvalds. All 
other trademarks are the property of their respective owners.
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Apple Information Access Toolkit software included. This software is based in part on the 
work of the Independent JPEG Group. THE PROXIMITY/MERRIAM WEBSTER DATABASE© 
Copyright 1984, 1990 Merriam-Webster Inc.  © Copyright 1984, 1990, 1993  - All rights 
Reserved Proximity Technology Inc.  THE PROXIMITY /FRANKLIN ELECTRONIC PUBLISHERS 
INC.- DATABASE © Copyright 1994 Franklin Electronic Publishers Inc. © Copyright 1994, 
1997 - All Rights Reserved Proximity Technology Inc.  THE PROXIMITY / MERRIAM WEBSTER 
INC./ FRANKLIN ELECTRONIC PUBLISHERS INC. DATABASE © Copyright 1990/1994 
Merriam-Webster Inc./Franklin Electronic Publishers Inc. © Copyright 1994, 1997 - All 
Rights Reserved Proximity Technology Inc.  THE PROXIMITY / WILLIAM COLLINS SONS & 
CO. LTD. DATABASE © Copyright 1984, 1990 William Collins Sons & Co. Ltd. © Copyright 
1988, 1990, 1997 - All Rights Reserved Proximity Technology Inc. THE PROXIMITY /Dr. LLUIS 
DE YZAGUIRRE I MAURA DATABASE © Copyright 1991 Dr, Llus de Yzaguirre  i Maura © 
Copyright 1991 - All Rights Reserved Proximity Technology Inc.  THE PROXIMITY / MUNKS-
GAARD INTERNATIONAL PUBLISHERS LTD. DATABASE © Copyright 1990 Munksgaard Inter-
national Publishers Ltd. © Copyright 1990 - All Rights Reserved Proximity Technology Inc.  
THE PROXIMITY / VAN DALE LEXICOGRAFIE BV DATABASE © Copyright 1990, 1995, 1997 
Van Dale Lexicografie bv © Copyright 1990, 1996, 1997 - All Rights Reserved Proximity 
Technology Inc.  THE PROXIMITY /IDE A.S. DATABASE © Copyright 1989, 1990 IDE a.s. © 
Copyright 1989, 1990 - All rights Reserved Proximity Technology Inc THE PROXIMITY /
HACHETTE DATABASE © Copyright 1992 Hatchette © Copyright 1992 - All Rights Reserved 
Proximity Technology Inc.  THE PROXIMITY /EDITIONS FERNAND NATHAN DATABASE © 
Copyright 1984 Editions Fernand Nathan © Copyright 1989 - All Rights Reserved Proximity 
Technology Inc.  THE PROXIMITY /TEXT & SATZ DATENTECHNIK DATABASE © Copyright 
1991 Text & Satz Datentechnik © Copyright 1991 - All Rights Reserved Proximity 
Technology Inc.  THE PROXIMITY/ BERTLESMANN LEXICON VERLANG DATABASE © 
Copyright 1997 Bertlesmann Lexicon Verlang © Copyright 1997 - All Rights Reserved 
Proximity Technology Inc. THE PROXIMITY/WILLIAM COLLINGS SONS & CO. LTD./
BERTLESMANN LEXICON VERLANG DATABASE © Copyright 1986/1997 William Collins Sons 
& Co. Ltd./ Bertlsmann Lexicon Verlang  © Copyright 1997 - All Rights Reserved Proximity 
Technology Inc.  THE PROXIMITY/ S. FISCHER VERLAG DATABASE © Copyright 1983  S. 
Fischer Verlag © Copyright 1997 - All Rights Reserved Proximity Technology Inc.  THE 
PROXIMITY/ZANICHELLI DATABASE © Copyright 1989 Zanichelli © Copyright 1989 - All 
Rights Reserved Proximity Technology Inc.  THE PROXIMITY/MORPHOLOGIC INC. 
DATABASE © Copyright 1997 Morphologic Inc. © Copyright 1997 - All Rights Reserved 
Proximity technology Inc.    THE PROXIMITY/ RUSSICON COMPANY LTD. DATABASE © 
Copyright 1993-1995 Russicon Company Ltd. © Copyright 1995 - All Rights Reserved 
Proximity Technology Inc.  THE PROXIMITY/ESPASSA-CALPE DATABASE © Copyright 1990 
Espassa-Calpe © Copyright 1990 - All Rights Reserved Proximity Technology Inc.  THE 
PROXIMITY/C.A. STROMBERG AB DATABASE © Copyright 1989 C.A. Stromberg AB © 
Copyright 1989 - All Rights Reserved Proximity Technology Inc

The TWAIN Toolkit is distributed as is.  The developer and distributors of the TWAIN Toolkit 
expressly disclaim all implied, express or statutory warranties including, without 
limitation, the implied warranties of merchantability, noninfringement of third party rights 
and fitness for a particular purpose.  Neither the developers nor the distributors will be 
liable for damages, whether direct, indirect, special, incidental, or consequential, as a 
result of the reproduction, modification, distribution, or other use of the TWAIN Toolkit.

Portions of Adobe Acrobat include technology used under license of Verity, Inc. and are 
copyrighted.
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Contains an implementation of the LZW algorithm licensed under U.S. Patent 4,558,302.

Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110, USA.

Notice to U.S. government end users. The software and documentation are “commercial 
items,” as that term is defined at 48 C.F.R. §2.101, consisting of “commercial computer 
software” and “commercial computer software documentation,” as such terms are used in 
48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 
48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the commercial computer 
software and commercial computer software documentation are being licensed to U.S. 
government end users (A) only as commercial items and (B) with only those rights as are 
granted to all other end users pursuant to the terms and conditions set forth in the Adobe 
standard commercial agreement for this software. Unpublished rights reserved under the 
copyright laws of the United States.
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